diff mbox series

ext4: avoid unused variable warning

Message ID 20181010142813.1918180-1-arnd@arndb.de
State New
Headers show
Series ext4: avoid unused variable warning | expand

Commit Message

Arnd Bergmann Oct. 10, 2018, 2:27 p.m. UTC
The two new variables are only used in an #ifdef, so they cause a
warning without CONFIG_QUOTA:

fs/ext4/super.c: In function 'parse_options':
fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name' [-Werror=unused-variable]
  char *p, *usr_qf_name, *grp_qf_name;
                          ^~~~~~~~~~~
fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name' [-Werror=unused-variable]
  char *p, *usr_qf_name, *grp_qf_name;

Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s error path")
Signed-off-by: Arnd Bergmann <arnd@arndb.de>

---
 fs/ext4/super.c | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

-- 
2.18.0

Comments

Theodore Ts'o Oct. 10, 2018, 7:26 p.m. UTC | #1
On Wed, Oct 10, 2018 at 04:27:58PM +0200, Arnd Bergmann wrote:
> The two new variables are only used in an #ifdef, so they cause a

> warning without CONFIG_QUOTA:

> 

> fs/ext4/super.c: In function 'parse_options':

> fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name' [-Werror=unused-variable]

>   char *p, *usr_qf_name, *grp_qf_name;

>                           ^~~~~~~~~~~

> fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name' [-Werror=unused-variable]

>   char *p, *usr_qf_name, *grp_qf_name;

> 

> Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s error path")

> Signed-off-by: Arnd Bergmann <arnd@arndb.de>


Hmm, I wonder if we should do something like:

#define EXT4_UNUSED_VAR __attribute__ ((unused))

and then we could do:

	char *p, *usr_qf_name EXT4_UNUSED_VAR, *grp_qf_name EXT4_UNUSED_VAR;

More generally, I wonder if this is something we should have defined
for the whole kernel, as opposed to a one-off hack that ACPI and ext4
subsystems use.  It's a little ugly, but I think it's much nicer than
having extra #ifdefs such as:

	char *p;
#ifdef CONFIG_QUOTA
	char *usr_qf_name, *grp_qf_name;
#endif

After all, the compiler is perfectly capable of ignoring variables
which are unused.  And if it's only because of an #ifdef later in the
function, it would be nice to not have an extra #ifdef in the variable
declarations.

						- Ted
Miguel Ojeda Oct. 10, 2018, 7:43 p.m. UTC | #2
Hi Ted,

On Wed, Oct 10, 2018 at 9:27 PM Theodore Y. Ts'o <tytso@mit.edu> wrote:
>

> On Wed, Oct 10, 2018 at 04:27:58PM +0200, Arnd Bergmann wrote:

> > The two new variables are only used in an #ifdef, so they cause a

> > warning without CONFIG_QUOTA:

> >

> > fs/ext4/super.c: In function 'parse_options':

> > fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name' [-Werror=unused-variable]

> >   char *p, *usr_qf_name, *grp_qf_name;

> >                           ^~~~~~~~~~~

> > fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name' [-Werror=unused-variable]

> >   char *p, *usr_qf_name, *grp_qf_name;

> >

> > Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s error path")

> > Signed-off-by: Arnd Bergmann <arnd@arndb.de>

>

> Hmm, I wonder if we should do something like:

>

> #define EXT4_UNUSED_VAR __attribute__ ((unused))


We have __maybe_unused already, so you can go ahead! :-)

(Also __always_unused, same definition as well, but here it does not may sense).

>

> and then we could do:

>

>         char *p, *usr_qf_name EXT4_UNUSED_VAR, *grp_qf_name EXT4_UNUSED_VAR;

>

> More generally, I wonder if this is something we should have defined

> for the whole kernel, as opposed to a one-off hack that ACPI and ext4

> subsystems use.  It's a little ugly, but I think it's much nicer than

> having extra #ifdefs such as:

>

>         char *p;

> #ifdef CONFIG_QUOTA

>         char *usr_qf_name, *grp_qf_name;

> #endif

>

> After all, the compiler is perfectly capable of ignoring variables

> which are unused.  And if it's only because of an #ifdef later in the

> function, it would be nice to not have an extra #ifdef in the variable

> declarations.


Indeed, it looks clean --- I like it.

Although I am not sure how people will feel about that :-) Someone may
argue that, for consistency, we shouldn't, because inside structs we
have to use #ifdefs still.

Cheers,
Miguel
Arnd Bergmann Oct. 10, 2018, 7:43 p.m. UTC | #3
On 10/10/18, Theodore Y. Ts'o <tytso@mit.edu> wrote:
> On Wed, Oct 10, 2018 at 04:27:58PM +0200, Arnd Bergmann wrote:

>> The two new variables are only used in an #ifdef, so they cause a

>> warning without CONFIG_QUOTA:

>>

>> fs/ext4/super.c: In function 'parse_options':

>> fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name'

>> [-Werror=unused-variable]

>>   char *p, *usr_qf_name, *grp_qf_name;

>>                           ^~~~~~~~~~~

>> fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name'

>> [-Werror=unused-variable]

>>   char *p, *usr_qf_name, *grp_qf_name;

>>

>> Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s

>> error path")

>> Signed-off-by: Arnd Bergmann <arnd@arndb.de>

>

> Hmm, I wonder if we should do something like:

>

> #define EXT4_UNUSED_VAR __attribute__ ((unused))

>

> and then we could do:

>

> 	char *p, *usr_qf_name EXT4_UNUSED_VAR, *grp_qf_name EXT4_UNUSED_VAR;

>

> More generally, I wonder if this is something we should have defined

> for the whole kernel, as opposed to a one-off hack that ACPI and ext4

> subsystems use.


I think the global __maybe_unused macro should work fine here.
I though about using that instead, but picked the #ifdef for
consistency with the other ifdef in the same function.

>  It's a little ugly, but I think it's much nicer than

> having extra #ifdefs such as:

>

> 	char *p;

> #ifdef CONFIG_QUOTA

> 	char *usr_qf_name, *grp_qf_name;

> #endif

>

> After all, the compiler is perfectly capable of ignoring variables

> which are unused.  And if it's only because of an #ifdef later in the

> function, it would be nice to not have an extra #ifdef in the variable

> declarations.


Another alternative that often results in more readable code is
to use a check like

        if (IS_ENABLED(CONFIG_QUOTA)) {
             ....
        }

around the conditional code instead of the #ifdef. This should usually
work unless the code accesses some struct members that are
also hidden in that #ifdef. I have not checked if that is the case here.

        Arnd
diff mbox series

Patch

diff --git a/fs/ext4/super.c b/fs/ext4/super.c
index e9ca8312457b..d60199510c94 100644
--- a/fs/ext4/super.c
+++ b/fs/ext4/super.c
@@ -1974,7 +1974,10 @@  static int parse_options(char *options, struct super_block *sb,
 			 int is_remount)
 {
 	struct ext4_sb_info *sbi = EXT4_SB(sb);
-	char *p, *usr_qf_name, *grp_qf_name;
+	char *p;
+#ifdef CONFIG_QUOTA
+	char *usr_qf_name, *grp_qf_name;
+#endif
 	substring_t args[MAX_OPT_ARGS];
 	int token;