epiphany: remove unused intltool build-dependency

Message ID 1497640847-9108-1-git-send-email-ross.burton@intel.com
State New
Headers show

Commit Message

Ross Burton June 16, 2017, 7:20 p.m.
Signed-off-by: Ross Burton <ross.burton@intel.com>

---
 meta/recipes-gnome/epiphany/epiphany_3.24.2.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.8.1

-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Comments

Khem Raj June 17, 2017, 1:11 a.m. | #1
On Fri, Jun 16, 2017 at 12:20 PM, Ross Burton <ross.burton@intel.com> wrote:
> Signed-off-by: Ross Burton <ross.burton@intel.com>

> ---

>  meta/recipes-gnome/epiphany/epiphany_3.24.2.bb | 2 +-

>  1 file changed, 1 insertion(+), 1 deletion(-)

>

> diff --git a/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb b/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb

> index b51f54f..77c1933 100644

> --- a/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb

> +++ b/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb

> @@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"

>

>  DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes avahi libnotify gcr \

>            gsettings-desktop-schemas gnome-desktop3 libxml2-native \

> -          intltool-native glib-2.0 glib-2.0-native json-glib"

> +          glib-2.0 glib-2.0-native json-glib"

>


is https://bugzilla.yoctoproject.org/show_bug.cgi?id=9374
no more relevant then ?

>  inherit gnomebase gsettings distro_features_check upstream-version-is-even gettext

>  REQUIRED_DISTRO_FEATURES = "x11"

> --

> 2.8.1

>

> --

> _______________________________________________

> Openembedded-core mailing list

> Openembedded-core@lists.openembedded.org

> http://lists.openembedded.org/mailman/listinfo/openembedded-core

-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core
Ross Burton June 17, 2017, 8:28 a.m. | #2
On 17 June 2017 at 02:11, Khem Raj <raj.khem@gmail.com> wrote:

> is https://bugzilla.yoctoproject.org/show_bug.cgi?id=9374

> no more relevant then ?

>


Correct: I've a local extension to insane.bbclass that checks for intltool
build dependencies but no use of intltool macros.

https://git.gnome.org/browse/epiphany/commit/configure.ac?h=3.24.2&id=b74f5c614e4cb9886e8ff6404f220b23df212be4
was the upstream commit to move away from intltool to standard gettext.

Ross
-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Patch hide | download patch | download mbox

diff --git a/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb b/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb
index b51f54f..77c1933 100644
--- a/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb
+++ b/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes avahi libnotify gcr \
 	   gsettings-desktop-schemas gnome-desktop3 libxml2-native \
-	   intltool-native glib-2.0 glib-2.0-native json-glib"
+	   glib-2.0 glib-2.0-native json-glib"
 
 inherit gnomebase gsettings distro_features_check upstream-version-is-even gettext
 REQUIRED_DISTRO_FEATURES = "x11"