[03/19] glibc: Enable obsoleted nsl

Message ID d0aa41ee8eef4b5f2d6290aaa2344dbda976816e.1498893436.git.raj.khem@gmail.com
State Superseded
Headers show
Series
  • Rework GCC PIE and security flags (take 3)
Related show

Commit Message

Khem Raj July 1, 2017, 2:23 p.m.
libnsl has been obsoleted in 2.26 and will be removed in future
until them we enable it

Signed-off-by: Khem Raj <raj.khem@gmail.com>

---
 meta/recipes-core/glibc/glibc_2.25.90.bb | 1 +
 1 file changed, 1 insertion(+)

-- 
2.13.2

-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Patch

diff --git a/meta/recipes-core/glibc/glibc_2.25.90.bb b/meta/recipes-core/glibc/glibc_2.25.90.bb
index b2f4db5181..bdbfd40ada 100644
--- a/meta/recipes-core/glibc/glibc_2.25.90.bb
+++ b/meta/recipes-core/glibc/glibc_2.25.90.bb
@@ -76,6 +76,7 @@  EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
                 --with-headers=${STAGING_INCDIR} \
                 --without-selinux \
                 --enable-obsolete-rpc \
+                --enable-obsolete-nsl \
                 --enable-tunables \
                 --enable-bind-now \
                 --enable-stack-protector=strong \