[v1,03/23] docker: include python-yaml in travis.docker

Message ID 20170717144848.11793-4-alex.bennee@linaro.org
State Superseded
Headers show
Series
  • Current Travis Queue
Related show

Commit Message

Alex Bennée July 17, 2017, 2:48 p.m.
Although the upstream Travis images don't need this library our
"travis-lite" scripts are written in python. This allows us to do:

  make docker-travis@travis J=10

and approximate a travis run on their default image.

Signed-off-by: Alex Bennée <alex.bennee@linaro.org>

---
 tests/docker/dockerfiles/travis.docker | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.13.0

Comments

Fam Zheng July 17, 2017, 10:42 p.m. | #1
On Mon, 07/17 15:48, Alex Bennée wrote:
> Although the upstream Travis images don't need this library our

> "travis-lite" scripts are written in python. This allows us to do:

> 

>   make docker-travis@travis J=10

> 

> and approximate a travis run on their default image.

> 

> Signed-off-by: Alex Bennée <alex.bennee@linaro.org>

> ---

>  tests/docker/dockerfiles/travis.docker | 2 +-

>  1 file changed, 1 insertion(+), 1 deletion(-)

> 

> diff --git a/tests/docker/dockerfiles/travis.docker b/tests/docker/dockerfiles/travis.docker

> index e4983ae2d3..a315f66ad9 100644

> --- a/tests/docker/dockerfiles/travis.docker

> +++ b/tests/docker/dockerfiles/travis.docker

> @@ -2,5 +2,5 @@ FROM quay.io/travisci/travis-ruby

>  RUN apt-get update

>  RUN apt-get -y build-dep qemu

>  RUN apt-get -y build-dep device-tree-compiler

> -RUN apt-get -y install python2.7 dh-autoreconf

> +RUN apt-get -y install python2.7 python-yaml dh-autoreconf

>  ENV FEATURES pyyaml

> -- 

> 2.13.0

> 


BTW, is the real travis yaml parser open source?

Reviewed-by: Fam Zheng <famz@redhat.com>

Patch hide | download patch | download mbox

diff --git a/tests/docker/dockerfiles/travis.docker b/tests/docker/dockerfiles/travis.docker
index e4983ae2d3..a315f66ad9 100644
--- a/tests/docker/dockerfiles/travis.docker
+++ b/tests/docker/dockerfiles/travis.docker
@@ -2,5 +2,5 @@  FROM quay.io/travisci/travis-ruby
 RUN apt-get update
 RUN apt-get -y build-dep qemu
 RUN apt-get -y build-dep device-tree-compiler
-RUN apt-get -y install python2.7 dh-autoreconf
+RUN apt-get -y install python2.7 python-yaml dh-autoreconf
 ENV FEATURES pyyaml