[v1,1/1] DEPENDENCIES: document changes in CUnit localization

Message ID 1504627211-31463-2-git-send-email-odpbot@yandex.ru
State New
Headers show
Series
  • [v1,1/1] DEPENDENCIES: document changes in CUnit localization
Related show

Commit Message

Github ODP bot Sept. 5, 2017, 4 p.m.
From: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>


Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>

---
/** Email created from pull request 162 (lumag:fix-deps)
 ** https://github.com/Linaro/odp/pull/162
 ** Patch: https://github.com/Linaro/odp/pull/162.patch
 ** Base sha: 42184679185ce0c979e065349360167e3fce6ca0
 ** Merge commit sha: 14eaeea369772a8d69c46395d2011a7c66ebf0a0
 **/
 DEPENDENCIES | 32 ++++++++++++++++++++------------
 1 file changed, 20 insertions(+), 12 deletions(-)

Patch

diff --git a/DEPENDENCIES b/DEPENDENCIES
index a194cad1..71c629ba 100644
--- a/DEPENDENCIES
+++ b/DEPENDENCIES
@@ -9,12 +9,13 @@  Prerequisites for building the OpenDataPlane (ODP) API
    automake
    autoconf
    libtool
+   pkg-config
 
    On Debian/Ubuntu systems:
-   $ sudo apt-get install automake autoconf libtool
+   $ sudo apt-get install automake autoconf libtool pkg-config
 
    On CentOS/RedHat/Fedora systems:
-   $ sudo yum install automake autoconf libtool
+   $ sudo yum install automake autoconf libtool pkgconfig
 
 3. Required libraries
 
@@ -199,11 +200,11 @@  Prerequisites for building the OpenDataPlane (ODP) API
 
 4.0 Packages needed to build API tests
 
-   Cunit test framework version 2.1-3 is required
-   Cunit prvodes a framework to run the API test suite that proves conformance to the
+   CUnit test framework version 2.1-3 is required
+   CUnit prvodes a framework to run the API test suite that proves conformance to the
    ODP API. The home page http://cunit.sourceforge.net/doc/introduction.html
 
-4.1 Native Cunit install
+4.1 Native CUnit install
 
    # Debian/Ubuntu
    $ apt-get install libcunit1-dev
@@ -232,20 +233,27 @@  Prerequisites for building the OpenDataPlane (ODP) API
    # reboot, before trying to run e.g. 'make distcheck'.
    sudo ldconfig
 
-4.3 Cross compile of Cunit
+4.3 Cross compile of CUnit
 
    $ git svn clone http://svn.code.sf.net/p/cunit/code/trunk cunit-code
    $ cd cunit-code
    $ ./bootstrap
    $ ./configure --host=arm-linux-gnueabihf --prefix=/home/${USER}/src/install-cunit
 
-4.4 Using Cunit with ODP
-   $ Add the configuration option to the regular configuration options
-   # Use the default path ...
-   ./configure  --enable-cunit
+4.4 Using CUnit with ODP
 
-   # ... OR the user defined path.
-   ./configure  --with-cunit-path=/home/<my_cunit_path>
+   Configure will automatically look for CUnit if validation testsuite is
+   enabled. By default it uses pkg-config to locate CUnit. Usually no
+   additional configuration will be required. Few corner cases:
+
+   # Systemwide CUnit if configure errors out with 'missing Version' message
+   ./configure CUNIT_CFLAGS="-I/usr/include" CUNIT_LIBS="-lcunit"
+
+   # User directory installation
+   ./configure PKG_CONFIG_PATH=/home/<my_cunit_path>/lib/pkgconfig
+
+   # ... OR directly specifying flags
+   ./configure CUNIT_CFLAGS="-I/home/<my_cunit_path>/include" CUNIT_LIBS="/home/<my_cunit_path>/lib -lcunit"
 
 5.0 Documentation Images & Doxygen