[API-NEXT,v1,16/19] DEPENDENCIES: document changes in CUnit localization

Message ID 1505156408-13887-17-git-send-email-odpbot@yandex.ru
State New
Headers show
Series
  • Untitled series #3957
Related show

Commit Message

Github ODP bot Sept. 11, 2017, 7 p.m.
From: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>


Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>

Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org>

Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>

---
/** Email created from pull request 173 (muvarov:api-next)
 ** https://github.com/Linaro/odp/pull/173
 ** Patch: https://github.com/Linaro/odp/pull/173.patch
 ** Base sha: 7fa8e2c97ed18f8dd6e95cbc78b7e668ccb98869
 ** Merge commit sha: 057be0905a62a157cc96a91743ea70e66e8554ca
 **/
 DEPENDENCIES | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)

Patch

diff --git a/DEPENDENCIES b/DEPENDENCIES
index a194cad1..e309b339 100644
--- a/DEPENDENCIES
+++ b/DEPENDENCIES
@@ -9,12 +9,13 @@  Prerequisites for building the OpenDataPlane (ODP) API
    automake
    autoconf
    libtool
+   pkg-config
 
    On Debian/Ubuntu systems:
-   $ sudo apt-get install automake autoconf libtool
+   $ sudo apt-get install automake autoconf libtool pkg-config
 
    On CentOS/RedHat/Fedora systems:
-   $ sudo yum install automake autoconf libtool
+   $ sudo yum install automake autoconf libtool pkgconfig
 
 3. Required libraries
 
@@ -199,11 +200,11 @@  Prerequisites for building the OpenDataPlane (ODP) API
 
 4.0 Packages needed to build API tests
 
-   Cunit test framework version 2.1-3 is required
-   Cunit prvodes a framework to run the API test suite that proves conformance to the
+   CUnit test framework version 2.1-3 is required
+   CUnit provides a framework to run the API test suite that proves conformance to the
    ODP API. The home page http://cunit.sourceforge.net/doc/introduction.html
 
-4.1 Native Cunit install
+4.1 Native CUnit install
 
    # Debian/Ubuntu
    $ apt-get install libcunit1-dev
@@ -223,7 +224,7 @@  Prerequisites for building the OpenDataPlane (ODP) API
    sudo make install
 
    # ... OR ... Install CUnit into user defined location. The same path is
-   # used in step 4.4 --with-cunit-path=/home/<my_cunit_path>
+   # used in step 4.4: PKG_CONFIG_PATH=/home/<my_cunit_path>/lib/pkgconfig
    ./configure --prefix=/home/<my_cunit_path>
    make
    make install
@@ -232,20 +233,24 @@  Prerequisites for building the OpenDataPlane (ODP) API
    # reboot, before trying to run e.g. 'make distcheck'.
    sudo ldconfig
 
-4.3 Cross compile of Cunit
+4.3 Cross compile of CUnit
 
    $ git svn clone http://svn.code.sf.net/p/cunit/code/trunk cunit-code
    $ cd cunit-code
    $ ./bootstrap
    $ ./configure --host=arm-linux-gnueabihf --prefix=/home/${USER}/src/install-cunit
 
-4.4 Using Cunit with ODP
-   $ Add the configuration option to the regular configuration options
-   # Use the default path ...
-   ./configure  --enable-cunit
+4.4 Using CUnit with ODP
 
-   # ... OR the user defined path.
-   ./configure  --with-cunit-path=/home/<my_cunit_path>
+   Configure will automatically look for CUnit if validation testsuite is
+   enabled. By default it uses pkg-config to locate CUnit. Usually no
+   additional configuration will be required. Few corner cases:
+
+   # User directory installation
+   ./configure PKG_CONFIG_PATH=/home/<my_cunit_path>/lib/pkgconfig
+
+   # ... OR directly specifying flags
+   ./configure CUNIT_CFLAGS="-I/home/<my_cunit_path>/include" CUNIT_LIBS="/home/<my_cunit_path>/lib -lcunit"
 
 5.0 Documentation Images & Doxygen