[v4,3/6] travis: don't use cross-pkg-config

Message ID 1505318407-21381-4-git-send-email-odpbot@yandex.ru
State Superseded
Headers show
Series
  • [v4,1/6] travis: fix powerpc test name
Related show

Commit Message

Github ODP bot Sept. 13, 2017, 4 p.m.
From: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>


Cross-pkg-config rewrites PKG_CONFIG_PATH to static value. Simulate it,
but allow further script to expand PKG_CONFIG_PATH value.

Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>

---
/** Email created from pull request 175 (lumag:build-x86)
 ** https://github.com/Linaro/odp/pull/175
 ** Patch: https://github.com/Linaro/odp/pull/175.patch
 ** Base sha: fb3f36cec108ce9c55241d9f0e66d4832a552b8a
 ** Merge commit sha: 053d08aa14dd4077b17b983bac6b9930801fbcba
 **/
 .travis.yml | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Patch

diff --git a/.travis.yml b/.travis.yml
index 1ca4b5af..b6e98184 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -82,8 +82,15 @@  before_install:
                   sudo -E apt-add-repository -y "deb http://ports.ubuntu.com trusty main" ;
                   sudo -E apt-add-repository -y "deb http://ports.ubuntu.com trusty-updates main" ;
                   sudo -E apt-get -y update || true ;
-                  sudo -E apt-get -y --no-install-suggests --no-install-recommends --force-yes install build-essential gcc-"$CROSS_GNU_TYPE" pkg-config-"$CROSS_GNU_TYPE" ;
+                  sudo -E apt-get -y --no-install-suggests --no-install-recommends --force-yes install build-essential ;
+                  if [ "$CROSS_ARCH" = "i386" ] ;
+                  then
+                        sudo -E apt-get -y --no-install-suggests --no-install-recommends --force-yes install gcc-multilib ;
+                  else
+                        sudo -E apt-get -y --no-install-suggests --no-install-recommends --force-yes install gcc-"$CROSS_GNU_TYPE" ;
+                  fi ;
                   sudo -E apt-get -y --no-install-suggests --no-install-recommends --force-yes install libc6-dev:"$CROSS_ARCH" libssl-dev:"$CROSS_ARCH" zlib1g-dev:"$CROSS_ARCH" libconfig-dev:"$CROSS_ARCH" ;
+                  export PKG_CONFIG_PATH=/usr/lib/${CROSS_MULTIARCH}/pkgconfig:/usr/${CROSS_MULTIARCH}/lib/pkgconfig ;
           fi
         - if test ! -L /usr/lib/ccache/${CC%% *} ; then sudo ln -s -t /usr/lib/ccache/ `which ${CC%% *}` ; fi
         - ccache -s