[03/29] linux-gen: ipsec: don't use __odp_force

Message ID 20171023111057.6328-4-dmitry.ereminsolenikov@linaro.org
State Superseded
Headers show
Series
  • restructure headers for ABI-compat/platform-optimized modes
Related show

Commit Message

Dmitry Eremin-Solenikov Oct. 23, 2017, 11:10 a.m.
__odp_force is not part of ODP API, so it should not be used directly.

Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>

---
 platform/linux-generic/odp_ipsec.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.14.2

Patch

diff --git a/platform/linux-generic/odp_ipsec.c b/platform/linux-generic/odp_ipsec.c
index e57736c2a792..7e833adee0a8 100644
--- a/platform/linux-generic/odp_ipsec.c
+++ b/platform/linux-generic/odp_ipsec.c
@@ -126,7 +126,7 @@  odp_u16sum_t _odp_chksum(void *buffer, int len)
 	sum += (sum >> 16);
 	result = ~sum;
 
-	return  (__odp_force odp_u16sum_t) result;
+	return  (odp_u16sum_t)result;
 }
 
 static inline int _odp_ipv4_csum(odp_packet_t pkt,