gstreamer1.0-python: Remove --enable-introspection

Message ID 20190406161948.9151-1-raj.khem@gmail.com
State New
Headers show
Series
  • gstreamer1.0-python: Remove --enable-introspection
Related show

Commit Message

Khem Raj April 6, 2019, 4:19 p.m.
This option is not available and recently it is reported as error

do_configure: QA Issue: gstreamer1.0-python: configur
e was passed unrecognised options: --enable-introspection [unknown-configure-option]

Signed-off-by: Khem Raj <raj.khem@gmail.com>

---
 meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb | 1 +
 1 file changed, 1 insertion(+)

-- 
2.21.0

-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Comments

Andreas Müller April 6, 2019, 6:27 p.m. | #1
On Sat, Apr 6, 2019 at 6:20 PM Khem Raj <raj.khem@gmail.com> wrote:
>

> This option is not available and recently it is reported as error

>

> do_configure: QA Issue: gstreamer1.0-python: configur

> e was passed unrecognised options: --enable-introspection [unknown-configure-option]

>

Send out a patch already addressing [1] but honestly I parts of this
parts more: remove option instead of ignoring.

Cann you add:

-inherit autotools pkgconfig distutils3-base upstream-version-is-even
gobject-introspection
+inherit autotools pkgconfig distutils3-base upstream-version-is-even
gobject-introspection distro_features_check
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"

or shall I send V3?

[1] http://lists.openembedded.org/pipermail/openembedded-core/2019-April/280958.html

Andreas
-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core
Andreas Müller April 6, 2019, 6:45 p.m. | #2
On Sat, Apr 6, 2019 at 8:27 PM Andreas Müller <schnitzeltony@gmail.com> wrote:
AArgh recent comment went out way too early.

This patch won't work if gobject-introspection-data is not in distro
features. Then there would be unknown configure option
--disable-introspection.

So what do others think: ignore unknown options (then my patch is OK) or remove?

Andreas
>
> On Sat, Apr 6, 2019 at 6:20 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > This option is not available and recently it is reported as error
> >
> > do_configure: QA Issue: gstreamer1.0-python: configur
> > e was passed unrecognised options: --enable-introspection [unknown-configure-option]
> >
> Send out a patch already addressing [1] but honestly I parts of this
> parts more: remove option instead of ignoring.
>
> Cann you add:
>
> -inherit autotools pkgconfig distutils3-base upstream-version-is-even
> gobject-introspection
> +inherit autotools pkgconfig distutils3-base upstream-version-is-even
> gobject-introspection distro_features_check
> +# gobject-introspection is mandatory and cannot be configured
> +REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
>
> or shall I send V3?
>
> [1] http://lists.openembedded.org/pipermail/openembedded-core/2019-April/280958.html
>
> Andreas
Khem Raj April 6, 2019, 7:04 p.m. | #3
On Sat, Apr 6, 2019 at 11:27 AM Andreas Müller <schnitzeltony@gmail.com> wrote:
>
> On Sat, Apr 6, 2019 at 6:20 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > This option is not available and recently it is reported as error
> >
> > do_configure: QA Issue: gstreamer1.0-python: configur
> > e was passed unrecognised options: --enable-introspection [unknown-configure-option]
> >
> Send out a patch already addressing [1] but honestly I parts of this
> parts more: remove option instead of ignoring.
>
> Cann you add:
>
> -inherit autotools pkgconfig distutils3-base upstream-version-is-even
> gobject-introspection
> +inherit autotools pkgconfig distutils3-base upstream-version-is-even
> gobject-introspection distro_features_check
> +# gobject-introspection is mandatory and cannot be configured
> +REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
>
> or shall I send V3?

seems better please do

>
> [1] http://lists.openembedded.org/pipermail/openembedded-core/2019-April/280958.html
>
> Andreas

Patch

diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
index 8d45ca2668..3358352128 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
@@ -18,6 +18,7 @@  S = "${WORKDIR}/${PNREAL}-${PV}"
 
 inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection
 
+EXTRA_OECONF_remove = "--enable-introspection"
 do_install_append() {
     # gstpythonplugin hardcodes the location of the libpython from the build
     # workspace and then fails at runtime. We can override it using