agross/ci-next boot bisection: v5.4-rc1-28-g3836faaf73f4 on beagle-xm

Message ID 5da7190b.1c69fb81.560a8.e3ae@mx.google.com
State New
Headers show
Series
  • agross/ci-next boot bisection: v5.4-rc1-28-g3836faaf73f4 on beagle-xm
Related show

Commit Message

kernelci.org bot Oct. 16, 2019, 1:20 p.m.
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* This automated bisection report was sent to you on the basis  *
* that you may be involved with the breaking commit it has      *
* found.  No manual investigation has been done to verify it,   *
* and the root cause of the problem may be somewhere else.      *
*                                                               *
* If you do send a fix, please include this trailer:            *
*   Reported-by: "kernelci.org bot" <bot@kernelci.org>          *
*                                                               *
* Hope this helps!                                              *
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

agross/ci-next boot bisection: v5.4-rc1-28-g3836faaf73f4 on beagle-xm

Summary:
  Start:      3836faaf73f4 Merge branches 'arm64-for-5.5', 'arm64-defconfog-for-5.5', 'defconfig-for-5.5' 'drivers-for-5.5' and 'dts-for-5.5' into for-next
  Details:    https://kernelci.org/boot/id/5da6ccfd59b5144bc3752596
  Plain log:  https://storage.kernelci.org//agross/ci-next/v5.4-rc1-28-g3836faaf73f4/arm/multi_v7_defconfig+CONFIG_SMP=n/gcc-8/lab-baylibre/boot-omap3-beagle-xm.txt
  HTML log:   https://storage.kernelci.org//agross/ci-next/v5.4-rc1-28-g3836faaf73f4/arm/multi_v7_defconfig+CONFIG_SMP=n/gcc-8/lab-baylibre/boot-omap3-beagle-xm.html
  Result:     0d7051999175 arm64: dts: msm8916-samsung-a5u: Override iris compatible

Checks:
  revert:     PASS
  verify:     PASS

Parameters:
  Tree:       agross
  URL:        https://git.kernel.org/pub/scm/linux/kernel/git/qcom/linux.git
  Branch:     ci-next
  Target:     beagle-xm
  CPU arch:   arm
  Lab:        lab-baylibre
  Compiler:   gcc-8
  Config:     multi_v7_defconfig+CONFIG_SMP=n
  Test suite: boot

Breaking commit found:

-------------------------------------------------------------------------------
commit 0d7051999175f97dfb1aa32e9008f08bf044a0a7
Author: Stephan Gerhold <stephan@gerhold.net>
Date:   Thu Aug 22 13:23:39 2019 +0200

    arm64: dts: msm8916-samsung-a5u: Override iris compatible
    
    msm8916.dtsi sets the iris compatible to "qcom,wcn3620".
    While WCN3620 seems to be used on most MSM8916 devices,
    MSM8916 can also be paired with another chip (e.g. for WiFi dual-band).
    
    A5U uses WCN3660B instead, so the compatible needs to be overridden
    to apply the correct configuration.
    
    However, simply using "qcom,wcn3660" would be incorrect,
    since WCN3660B requires a slightly different regulator configuration
    compared to WCN3660.
    
    Instead, it requires the same configuration as "qcom,wcn3680".
    Replace the compatible with "qcom,wcn3680" for A5U to make WCNSS
    work correctly.
    
    Signed-off-by: Stephan Gerhold <stephan@gerhold.net>

    Signed-off-by: Bjorn Andersson <bjorn.andersson@linaro.org>


-------------------------------------------------------------------------------


Git bisection log:

-------------------------------------------------------------------------------
git bisect start
# good: [54ecb8f7028c5eb3d740bb82b0f1d90f2df63c5c] Linux 5.4-rc1
git bisect good 54ecb8f7028c5eb3d740bb82b0f1d90f2df63c5c
# bad: [3836faaf73f4380c8f9632723be4ee82f4e50196] Merge branches 'arm64-for-5.5', 'arm64-defconfog-for-5.5', 'defconfig-for-5.5' 'drivers-for-5.5' and 'dts-for-5.5' into for-next
git bisect bad 3836faaf73f4380c8f9632723be4ee82f4e50196
# good: [acbf73bfa02881ba9e0532ba1a5f5beec573af9f] soc: qcom: llcc: Move regmap config to local variable
git bisect good acbf73bfa02881ba9e0532ba1a5f5beec573af9f
# bad: [e38161bd325ea541ef2f258d8e28281077dde524] arm64: dts: apq8096-db820c: Increase load on l21 for SDCARD
git bisect bad e38161bd325ea541ef2f258d8e28281077dde524
# bad: [0d7051999175f97dfb1aa32e9008f08bf044a0a7] arm64: dts: msm8916-samsung-a5u: Override iris compatible
git bisect bad 0d7051999175f97dfb1aa32e9008f08bf044a0a7
# good: [8a250aa6eccdd54aebc62165c0c1fe250fee0338] arm64: dts: qcom: qcs404: add the watchdog node
git bisect good 8a250aa6eccdd54aebc62165c0c1fe250fee0338
# good: [efb9e0df7d8df9f6ccc4a02a52e56fb6e379e193] arm64: dts: msm8916-samsung-a2015: Enable WCNSS for WiFi and BT
git bisect good efb9e0df7d8df9f6ccc4a02a52e56fb6e379e193
# first bad commit: [0d7051999175f97dfb1aa32e9008f08bf044a0a7] arm64: dts: msm8916-samsung-a5u: Override iris compatible
-------------------------------------------------------------------------------

Patch

diff --git a/arch/arm64/boot/dts/qcom/msm8916-samsung-a5u-eur.dts b/arch/arm64/boot/dts/qcom/msm8916-samsung-a5u-eur.dts
index 1aa59da98495..6629a621139c 100644
--- a/arch/arm64/boot/dts/qcom/msm8916-samsung-a5u-eur.dts
+++ b/arch/arm64/boot/dts/qcom/msm8916-samsung-a5u-eur.dts
@@ -8,3 +8,9 @@ 
 	model = "Samsung Galaxy A5U (EUR)";
 	compatible = "samsung,a5u-eur", "qcom,msm8916";
 };
+
+&pronto {
+	iris {
+		compatible = "qcom,wcn3680";
+	};
+};