Warning message from 'make nsdeps' when namespace is lower cases

Message ID CAK7LNAQ8Wi1zED0rYJhk9tYi5-jgCoyeHNtofvgKet4ZTzKFcA@mail.gmail.com
State New
Headers show
Series
  • Warning message from 'make nsdeps' when namespace is lower cases
Related show

Commit Message

Masahiro Yamada Oct. 29, 2019, 1:12 p.m.
Hi.

When I was playing with 'make nsdeps',
I saw a new warning.

If I rename USB_STORAGE to usb_storage,
I see 'warning: line 15: should usb_storage be a metavariable?'
Why? I think it comes from spatch.
It should be technically OK to use either upper or lower cases
for the namespace name.


Just apply the following, and try 'make nsdeps'.












-- 
Best Regards
Masahiro Yamada

Comments

Julia Lawall Oct. 29, 2019, 1:38 p.m. | #1
On Tue, 29 Oct 2019, Masahiro Yamada wrote:

> Hi.

>

> When I was playing with 'make nsdeps',

> I saw a new warning.

>

> If I rename USB_STORAGE to usb_storage,

> I see 'warning: line 15: should usb_storage be a metavariable?'

> Why? I think it comes from spatch.


Yes, it would come from spatch.

> It should be technically OK to use either upper or lower cases

> for the namespace name.


What is normally wanted?  Uppercase or lowercase?

julia

>

> Just apply the following, and try 'make nsdeps'.

>

>

> diff --git a/drivers/usb/storage/Makefile b/drivers/usb/storage/Makefile

> index 46635fa4a340..6f817d65c26b 100644

> --- a/drivers/usb/storage/Makefile

> +++ b/drivers/usb/storage/Makefile

> @@ -8,7 +8,7 @@

>

>  ccflags-y := -I $(srctree)/drivers/scsi

>

> -ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=USB_STORAGE

> +ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=usb_storage

>

>  obj-$(CONFIG_USB_UAS)          += uas.o

>  obj-$(CONFIG_USB_STORAGE)      += usb-storage.o

>

>

>

>

>

>

>

>

>

>

> --

> Best Regards

> Masahiro Yamada

>
Matthias Maennich Oct. 29, 2019, 2:37 p.m. | #2
Hi!

On Tue, Oct 29, 2019 at 02:38:36PM +0100, Julia Lawall wrote:
>

>

>On Tue, 29 Oct 2019, Masahiro Yamada wrote:

>

>> Hi.

>>

>> When I was playing with 'make nsdeps',

>> I saw a new warning.

>>

>> If I rename USB_STORAGE to usb_storage,

>> I see 'warning: line 15: should usb_storage be a metavariable?'

>> Why? I think it comes from spatch.

>

>Yes, it would come from spatch.

>

>> It should be technically OK to use either upper or lower cases

>> for the namespace name.

>

>What is normally wanted?  Uppercase or lowercase?


There is no (documented) preference or convention yet. The existing
namespaces (USB_STORAGE and MCB) use upper case. While technically both
should work, I have a personal preference for consistently using upper
case. Is there a way to suppress this warning as I agree that it might
be confusing?

Cheers,
Matthias

>

>julia

>

>>

>> Just apply the following, and try 'make nsdeps'.

>>

>>

>> diff --git a/drivers/usb/storage/Makefile b/drivers/usb/storage/Makefile

>> index 46635fa4a340..6f817d65c26b 100644

>> --- a/drivers/usb/storage/Makefile

>> +++ b/drivers/usb/storage/Makefile

>> @@ -8,7 +8,7 @@

>>

>>  ccflags-y := -I $(srctree)/drivers/scsi

>>

>> -ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=USB_STORAGE

>> +ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=usb_storage

>>

>>  obj-$(CONFIG_USB_UAS)          += uas.o

>>  obj-$(CONFIG_USB_STORAGE)      += usb-storage.o

>>

>>

>>

>>

>>

>>

>>

>>

>>

>>

>> --

>> Best Regards

>> Masahiro Yamada

>>
Julia Lawall Oct. 29, 2019, 2:45 p.m. | #3
On Tue, 29 Oct 2019, Matthias Maennich wrote:

> Hi!

>

> On Tue, Oct 29, 2019 at 02:38:36PM +0100, Julia Lawall wrote:

> >

> >

> > On Tue, 29 Oct 2019, Masahiro Yamada wrote:

> >

> > > Hi.

> > >

> > > When I was playing with 'make nsdeps',

> > > I saw a new warning.

> > >

> > > If I rename USB_STORAGE to usb_storage,

> > > I see 'warning: line 15: should usb_storage be a metavariable?'

> > > Why? I think it comes from spatch.

> >

> > Yes, it would come from spatch.

> >

> > > It should be technically OK to use either upper or lower cases

> > > for the namespace name.

> >

> > What is normally wanted?  Uppercase or lowercase?

>

> There is no (documented) preference or convention yet. The existing

> namespaces (USB_STORAGE and MCB) use upper case. While technically both

> should work, I have a personal preference for consistently using upper

> case. Is there a way to suppress this warning as I agree that it might

> be confusing?


The warning is not intentional in this case.  I will have to fix
Coccinelle, but I can't do it until next week.

julia

>

> Cheers,

> Matthias

>

> >

> > julia

> >

> > >

> > > Just apply the following, and try 'make nsdeps'.

> > >

> > >

> > > diff --git a/drivers/usb/storage/Makefile b/drivers/usb/storage/Makefile

> > > index 46635fa4a340..6f817d65c26b 100644

> > > --- a/drivers/usb/storage/Makefile

> > > +++ b/drivers/usb/storage/Makefile

> > > @@ -8,7 +8,7 @@

> > >

> > >  ccflags-y := -I $(srctree)/drivers/scsi

> > >

> > > -ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=USB_STORAGE

> > > +ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=usb_storage

> > >

> > >  obj-$(CONFIG_USB_UAS)          += uas.o

> > >  obj-$(CONFIG_USB_STORAGE)      += usb-storage.o

> > >

> > >

> > >

> > >

> > >

> > >

> > >

> > >

> > >

> > >

> > > --

> > > Best Regards

> > > Masahiro Yamada

> > >

>

Patch

diff --git a/drivers/usb/storage/Makefile b/drivers/usb/storage/Makefile
index 46635fa4a340..6f817d65c26b 100644
--- a/drivers/usb/storage/Makefile
+++ b/drivers/usb/storage/Makefile
@@ -8,7 +8,7 @@ 

 ccflags-y := -I $(srctree)/drivers/scsi

-ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=USB_STORAGE
+ccflags-y += -DDEFAULT_SYMBOL_NAMESPACE=usb_storage

 obj-$(CONFIG_USB_UAS)          += uas.o
 obj-$(CONFIG_USB_STORAGE)      += usb-storage.o