video: amba-clcd: Select FB_MODE_HELPERS

Message ID 1406908430-18487-1-git-send-email-broonie@kernel.org
State New
Headers show

Commit Message

Mark Brown Aug. 1, 2014, 3:53 p.m.
From: Mark Brown <broonie@linaro.org>

The AMBA CLCD driver uses fb_videomode_from_videomode() so it needs to
select DB_MODE_HELPERS as well as VIDEOMODE_HELPERS.

Signed-off-by: Mark Brown <broonie@linaro.org>
---
 drivers/video/fbdev/Kconfig | 1 +
 1 file changed, 1 insertion(+)

Comments

Russell King - ARM Linux Aug. 1, 2014, 6:27 p.m. | #1
On Fri, Aug 01, 2014 at 04:53:50PM +0100, Mark Brown wrote:
> From: Mark Brown <broonie@linaro.org>
> 
> The AMBA CLCD driver uses fb_videomode_from_videomode() so it needs to
> select DB_MODE_HELPERS as well as VIDEOMODE_HELPERS.

It doesn't, not as I designed it at least.  It depends what other people
have done to my driver...
Mark Brown Aug. 1, 2014, 6:48 p.m. | #2
On Fri, Aug 01, 2014 at 07:27:03PM +0100, Russell King - ARM Linux wrote:
> On Fri, Aug 01, 2014 at 04:53:50PM +0100, Mark Brown wrote:

> > The AMBA CLCD driver uses fb_videomode_from_videomode() so it needs to
> > select DB_MODE_HELPERS as well as VIDEOMODE_HELPERS.

> It doesn't, not as I designed it at least.  It depends what other people
> have done to my driver...

Ah, sorry - I didn't notice that this is as a result of an out of tree
patch I'm carrying adding DT support (which I'd forgotten all about as
I've needed it for so long).  Please disregard this patch.
Tomi Valkeinen Aug. 4, 2014, 6:48 a.m. | #3
Hi,

On 01/08/14 18:53, Mark Brown wrote:
> From: Mark Brown <broonie@linaro.org>
> 
> The AMBA CLCD driver uses fb_videomode_from_videomode() so it needs to
> select DB_MODE_HELPERS as well as VIDEOMODE_HELPERS.
> 
> Signed-off-by: Mark Brown <broonie@linaro.org>
> ---
>  drivers/video/fbdev/Kconfig | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/video/fbdev/Kconfig b/drivers/video/fbdev/Kconfig
> index 37d473f..e222048 100644
> --- a/drivers/video/fbdev/Kconfig
> +++ b/drivers/video/fbdev/Kconfig
> @@ -280,6 +280,7 @@ config FB_ARMCLCD
>  	select FB_CFB_FILLRECT
>  	select FB_CFB_COPYAREA
>  	select FB_CFB_IMAGEBLIT
> +	select FB_MODE_HELPERS
>  	select VIDEOMODE_HELPERS if OF
>  	help
>  	  This framebuffer device driver is for the ARM PrimeCell PL110

Pawel sent a patch fixing the same issue. I've applied that one.

 Tomi

Patch

diff --git a/drivers/video/fbdev/Kconfig b/drivers/video/fbdev/Kconfig
index 37d473f..e222048 100644
--- a/drivers/video/fbdev/Kconfig
+++ b/drivers/video/fbdev/Kconfig
@@ -280,6 +280,7 @@  config FB_ARMCLCD
 	select FB_CFB_FILLRECT
 	select FB_CFB_COPYAREA
 	select FB_CFB_IMAGEBLIT
+	select FB_MODE_HELPERS
 	select VIDEOMODE_HELPERS if OF
 	help
 	  This framebuffer device driver is for the ARM PrimeCell PL110