diff mbox

[Xen-devel,v2,04/41] arm/acpi : add arm specific acpi header file

Message ID 1431893048-5214-5-git-send-email-parth.dixit@linaro.org
State New
Headers show

Commit Message

Parth Dixit May 17, 2015, 8:03 p.m. UTC
add architecture specific definitions and calls
required for acpi in new header file

Signed-off-by: Parth Dixit <parth.dixit@linaro.org>
---
 xen/include/asm-arm/acpi.h | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 xen/include/asm-arm/acpi.h

Comments

Parth Dixit May 24, 2015, 5:59 a.m. UTC | #1
On 18 May 2015 at 18:42, Julien Grall <julien.grall.oss@gmail.com> wrote:

> Hi Parth,
>
> On 17/05/15 21:03, Parth Dixit wrote:
> > +#ifndef _ASM_ARM64_ACPI_H
> > +#define _ASM_ARM64_ACPI_H
>
> s/_ASM_ARM64_ACPI_H/_ASM_ARM_ACPI_H/
>
> > +
> > +#include <xen/init.h>
> > +
> > +#define COMPILER_DEPENDENT_INT64   long long
> > +#define COMPILER_DEPENDENT_UINT64  unsigned long long
> > +
> > +extern bool_t acpi_disabled;
> > +/* Basic configuration for ACPI */
> > +static inline void disable_acpi(void)
> > +{
> > +    acpi_disabled = 1;
> > +}
>
> It makes a little sense to add the prototype of acpi_disabled without
> effectively declaring it.
>
> Also, the code is very similar to the x86. It would make sense to
> factorize it (disable_acpi, acpi parameters...) in a common place.
>
> sure, i will take care in next patch set.

> > +#endif /*_ASM_ARM_ACPI_H*/
> >
>
> Regards,
>
> --
> Julien Grall
>
Parth Dixit July 5, 2015, 1:02 p.m. UTC | #2
+shannon

On 24 May 2015 at 11:29, Parth Dixit <parth.dixit@linaro.org> wrote:
>
>
> On 18 May 2015 at 18:42, Julien Grall <julien.grall.oss@gmail.com> wrote:
>>
>> Hi Parth,
>>
>> On 17/05/15 21:03, Parth Dixit wrote:
>> > +#ifndef _ASM_ARM64_ACPI_H
>> > +#define _ASM_ARM64_ACPI_H
>>
>> s/_ASM_ARM64_ACPI_H/_ASM_ARM_ACPI_H/
>>
>> > +
>> > +#include <xen/init.h>
>> > +
>> > +#define COMPILER_DEPENDENT_INT64   long long
>> > +#define COMPILER_DEPENDENT_UINT64  unsigned long long
>> > +
>> > +extern bool_t acpi_disabled;
>> > +/* Basic configuration for ACPI */
>> > +static inline void disable_acpi(void)
>> > +{
>> > +    acpi_disabled = 1;
>> > +}
>>
>> It makes a little sense to add the prototype of acpi_disabled without
>> effectively declaring it.
>>
>> Also, the code is very similar to the x86. It would make sense to
>> factorize it (disable_acpi, acpi parameters...) in a common place.
>>
> sure, i will take care in next patch set.
>>
>> > +#endif /*_ASM_ARM_ACPI_H*/
>> >
>>
>> Regards,
>>
>> --
>> Julien Grall
>
>
diff mbox

Patch

diff --git a/xen/include/asm-arm/acpi.h b/xen/include/asm-arm/acpi.h
new file mode 100644
index 0000000..f771056
--- /dev/null
+++ b/xen/include/asm-arm/acpi.h
@@ -0,0 +1,38 @@ 
+/*
+ *  Copyright (C) 2014, Naresh Bhat <naresh.bhat@linaro.org>
+ *
+ * ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ *
+ *  This program is free software; you can redistribute it and/or modify
+ *  it under the terms of the GNU General Public License as published by
+ *  the Free Software Foundation; either version 2 of the License, or
+ *  (at your option) any later version.
+ *
+ *  This program is distributed in the hope that it will be useful,
+ *  but WITHOUT ANY WARRANTY; without even the implied warranty of
+ *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ *  GNU General Public License for more details.
+ *
+ *  You should have received a copy of the GNU General Public License
+ *  along with this program; if not, write to the Free Software
+ *  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+ *
+ * ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ */
+
+#ifndef _ASM_ARM64_ACPI_H
+#define _ASM_ARM64_ACPI_H
+
+#include <xen/init.h>
+
+#define COMPILER_DEPENDENT_INT64   long long
+#define COMPILER_DEPENDENT_UINT64  unsigned long long
+
+extern bool_t acpi_disabled;
+/* Basic configuration for ACPI */
+static inline void disable_acpi(void)
+{
+    acpi_disabled = 1;
+}
+
+#endif /*_ASM_ARM_ACPI_H*/