[3/5] pkg/rpm: fix dnf builddep

Message ID 1447679776-22461-4-git-send-email-anders.roxell@linaro.org
State New
Headers show

Commit Message

Anders Roxell Nov. 16, 2015, 1:16 p.m.
Need to be a value and not a string in order to install the build
requires with: dnf builddep pkg/rpm/odp.spec

Reported-by: Riku Voipio <riku.voipio@linaro.org>
Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
Reviewed-by: Riku Voipio <riku.voipio@linaro.org>
---
 pkg/rpm/odp.spec | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Maxim Uvarov Nov. 18, 2015, 10:33 a.m. | #1
On 11/16/2015 16:16, Anders Roxell wrote:
> Need to be a value and not a string in order to install the build
> requires with: dnf builddep pkg/rpm/odp.spec
>
> Reported-by: Riku Voipio <riku.voipio@linaro.org>
> Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
> Reviewed-by: Riku Voipio <riku.voipio@linaro.org>
> ---
>   pkg/rpm/odp.spec | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/pkg/rpm/odp.spec b/pkg/rpm/odp.spec
> index eb756ce..9dc2258 100644
> --- a/pkg/rpm/odp.spec
> +++ b/pkg/rpm/odp.spec
> @@ -4,7 +4,7 @@
>   # SPDX-License-Identifier:     BSD-3-Clause
>   
>   Name: opendataplane
> -Version: Dummy that will be replaced!
> +Version: 1.4
what is the plan with updating that version?

Maxim.
>   Release: 1
>   Packager: anders.roxell@linaro.org
>   URL: http://opendataplane.org
Anders Roxell Nov. 18, 2015, 10:35 a.m. | #2
On 18 November 2015 at 11:33, Maxim Uvarov <maxim.uvarov@linaro.org> wrote:
> On 11/16/2015 16:16, Anders Roxell wrote:
>>
>> Need to be a value and not a string in order to install the build
>> requires with: dnf builddep pkg/rpm/odp.spec
>>
>> Reported-by: Riku Voipio <riku.voipio@linaro.org>
>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
>> Reviewed-by: Riku Voipio <riku.voipio@linaro.org>
>> ---
>>   pkg/rpm/odp.spec | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/pkg/rpm/odp.spec b/pkg/rpm/odp.spec
>> index eb756ce..9dc2258 100644
>> --- a/pkg/rpm/odp.spec
>> +++ b/pkg/rpm/odp.spec
>> @@ -4,7 +4,7 @@
>>   # SPDX-License-Identifier:     BSD-3-Clause
>>     Name: opendataplane
>> -Version: Dummy that will be replaced!
>> +Version: 1.4
>
> what is the plan with updating that version?

The same plan as the dummy string...
The scripts/buildrpm will take care of that.

Cheers,
Anders

Patch

diff --git a/pkg/rpm/odp.spec b/pkg/rpm/odp.spec
index eb756ce..9dc2258 100644
--- a/pkg/rpm/odp.spec
+++ b/pkg/rpm/odp.spec
@@ -4,7 +4,7 @@ 
 # SPDX-License-Identifier:     BSD-3-Clause
 
 Name: opendataplane
-Version: Dummy that will be replaced!
+Version: 1.4
 Release: 1
 Packager: anders.roxell@linaro.org
 URL: http://opendataplane.org