diff mbox series

[for-6.2,3/3] wifi: brcmfmac: change cfg80211_set_channel() name and signature

Message ID 20230103124117.271988-4-arend.vanspriel@broadcom.com
State New
Headers show
Series wifi: brcmfmac: regression fixes | expand

Commit Message

Arend van Spriel Jan. 3, 2023, 12:41 p.m. UTC
The function cfg80211_set_channel() is an static function in brcmfmac
but the name is misleading. Hence rename it with 'brcmf' prefix. Also
changing the parameters to avoid additional conversions.

Signed-off-by: Arend van Spriel <arend.vanspriel@broadcom.com>
---
 .../net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c    | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

Comments

Kalle Valo Jan. 9, 2023, 3:50 p.m. UTC | #1
Arend van Spriel <arend.vanspriel@broadcom.com> writes:

> The function cfg80211_set_channel() is an static function in brcmfmac
> but the name is misleading. Hence rename it with 'brcmf' prefix. Also
> changing the parameters to avoid additional conversions.
>
> Signed-off-by: Arend van Spriel <arend.vanspriel@broadcom.com>

If I understood correctly this patch 3 is for wireless-next. So adding a
reminder for myself to _not_ take this to wireless tree :)

(I wish patchwork would have a support for offline notes so I would not
need to send emails like this)
Arend van Spriel Jan. 9, 2023, 5:38 p.m. UTC | #2
On January 9, 2023 4:51:03 PM Kalle Valo <kvalo@kernel.org> wrote:

> Arend van Spriel <arend.vanspriel@broadcom.com> writes:
>
>> The function cfg80211_set_channel() is an static function in brcmfmac
>> but the name is misleading. Hence rename it with 'brcmf' prefix. Also
>> changing the parameters to avoid additional conversions.
>>
>> Signed-off-by: Arend van Spriel <arend.vanspriel@broadcom.com>
>
> If I understood correctly this patch 3 is for wireless-next. So adding a
> reminder for myself to _not_ take this to wireless tree :)

FWIW you understood correctly.

Gr. AvS
Kalle Valo Feb. 13, 2023, 4:54 p.m. UTC | #3
Arend van Spriel <arend.vanspriel@broadcom.com> wrote:

> The function cfg80211_set_channel() is an static function in brcmfmac
> but the name is misleading. Hence rename it with 'brcmf' prefix. Also
> changing the parameters to avoid additional conversions.
> 
> Signed-off-by: Arend van Spriel <arend.vanspriel@broadcom.com>

Patch applied to wireless-next.git, thanks.

5fac18583a00 wifi: brcmfmac: change cfg80211_set_channel() name and signature
diff mbox series

Patch

diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
index b115902eb475..a9690ec4c850 100644
--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
@@ -7928,13 +7928,10 @@  brcmf_dump_obss(struct brcmf_if *ifp, struct cca_msrmnt_query req,
 }
 
 static s32
-cfg80211_set_channel(struct wiphy *wiphy, struct net_device *dev,
-		     struct ieee80211_channel *chan,
-		     enum nl80211_channel_type channel_type)
+brcmf_set_channel(struct brcmf_cfg80211_info *cfg, struct ieee80211_channel *chan)
 {
 	u16 chspec = 0;
 	int err = 0;
-	struct brcmf_cfg80211_info *cfg = wiphy_to_cfg(wiphy);
 	struct brcmf_if *ifp = netdev_priv(cfg_to_ndev(cfg));
 
 	if (chan->flags & IEEE80211_CHAN_DISABLED)
@@ -7994,7 +7991,7 @@  brcmf_cfg80211_dump_survey(struct wiphy *wiphy, struct net_device *ndev,
 
 	/* Setting current channel to the requested channel */
 	info->filled = 0;
-	if (cfg80211_set_channel(wiphy, ndev, info->channel, NL80211_CHAN_HT20))
+	if (brcmf_set_channel(cfg, info->channel))
 		return 0;
 
 	/* Disable mpc */