diff mbox series

[v1,1/1] gpiolib: Get rid of devprop prefix in one function

Message ID 20230309185600.84948-1-andriy.shevchenko@linux.intel.com
State Accepted
Commit 0c5ebb4c03308c0a544b5c1e0a33f0a63c40bc7e
Headers show
Series [v1,1/1] gpiolib: Get rid of devprop prefix in one function | expand

Commit Message

Andy Shevchenko March 9, 2023, 6:56 p.m. UTC
The devprop prefix in the devprop_gpiochip_set_names() adds confusion.
Get rid of it.

Note we have more than one function in the same module that handles
one or more device properties. This change will unify the naming schema
for all of them.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 drivers/gpio/gpiolib.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Linus Walleij March 13, 2023, 10:28 a.m. UTC | #1
On Thu, Mar 9, 2023 at 7:59 PM Andy Shevchenko
<andriy.shevchenko@linux.intel.com> wrote:

> The devprop prefix in the devprop_gpiochip_set_names() adds confusion.
> Get rid of it.
>
> Note we have more than one function in the same module that handles
> one or more device properties. This change will unify the naming schema
> for all of them.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>

Reviewed-by: Linus Walleij <linus.walleij@linaro.org>

Yours,
Linus Walleij
Bartosz Golaszewski March 15, 2023, 9:41 a.m. UTC | #2
On Thu, Mar 9, 2023 at 7:59 PM Andy Shevchenko
<andriy.shevchenko@linux.intel.com> wrote:
>
> The devprop prefix in the devprop_gpiochip_set_names() adds confusion.
> Get rid of it.
>
> Note we have more than one function in the same module that handles
> one or more device properties. This change will unify the naming schema
> for all of them.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---

Applied, thanks!

Bart
diff mbox series

Patch

diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
index 45f79aee451a..8ecfe3afde1e 100644
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
@@ -374,7 +374,7 @@  static int gpiochip_set_desc_names(struct gpio_chip *gc)
 }
 
 /*
- * devprop_gpiochip_set_names - Set GPIO line names using device properties
+ * gpiochip_set_names - Set GPIO line names using device properties
  * @chip: GPIO chip whose lines should be named, if possible
  *
  * Looks for device property "gpio-line-names" and if it exists assigns
@@ -382,7 +382,7 @@  static int gpiochip_set_desc_names(struct gpio_chip *gc)
  * names belong to the underlying firmware node and should not be released
  * by the caller.
  */
-static int devprop_gpiochip_set_names(struct gpio_chip *chip)
+static int gpiochip_set_names(struct gpio_chip *chip)
 {
 	struct gpio_device *gdev = chip->gpiodev;
 	struct device *dev = &gdev->dev;
@@ -834,7 +834,7 @@  int gpiochip_add_data_with_key(struct gpio_chip *gc, void *data,
 		if (ret)
 			goto err_remove_from_list;
 	}
-	ret = devprop_gpiochip_set_names(gc);
+	ret = gpiochip_set_names(gc);
 	if (ret)
 		goto err_remove_from_list;