dmaengine: st_fdma: Update st_fdma to 'depends on REMOTEPROC'.

Message ID 1477039465-31121-1-git-send-email-peter.griffin@linaro.org
State Superseded
Headers show

Commit Message

Peter Griffin Oct. 21, 2016, 8:44 a.m.
During randconfig builds you can get the following warning
"warning: (ST_FDMA) selects ST_SLIM_REMOTEPROC which has unmet direct
 dependencies (REMOTEPROC)"

randconfig builds should always build without any warnings so
update fdma to depend on REMOTEPROC so this can not happen.

Signed-off-by: Peter Griffin <peter.griffin@linaro.org>

Reported-by: Arnd Bergmann <arnd@arndb.de>
Tested-by: Arnd Bergmann <arnd@arndb.de>

---
 drivers/dma/Kconfig | 1 +
 1 file changed, 1 insertion(+)

-- 
1.9.1

Comments

Vinod Koul Nov. 3, 2016, 1:15 p.m. | #1
On Fri, 2016-10-21 at 09:44 +0100, Peter Griffin wrote:
> During randconfig builds you can get the following warning

> "warning: (ST_FDMA) selects ST_SLIM_REMOTEPROC which has unmet direct

>  dependencies (REMOTEPROC)"

> 

> randconfig builds should always build without any warnings so

> update fdma to depend on REMOTEPROC so this can not happen.


Applied, thanks

-- 
~Vinod

Patch

diff --git a/drivers/dma/Kconfig b/drivers/dma/Kconfig
index 661f217..6b96710 100644
--- a/drivers/dma/Kconfig
+++ b/drivers/dma/Kconfig
@@ -438,6 +438,7 @@  config STE_DMA40
 config ST_FDMA
 	tristate "ST FDMA dmaengine support"
 	depends on ARCH_STI
+	depends on REMOTEPROC
 	select ST_SLIM_REMOTEPROC
 	select DMA_ENGINE
 	select DMA_VIRTUAL_CHANNELS