drm: fix MMU dependencies

Message ID 1484211456-5759-1-git-send-email-benjamin.gaignard@linaro.org
State Accepted
Commit 7e53c284ec7e056e2f94faba623c6c2759552464
Headers show

Commit Message

Benjamin Gaignard Jan. 12, 2017, 8:57 a.m.
DRM_VM and DRM_LEGACY shouldn't be selected if MMU isn't set.

Fixes: 62a0d98a188c ("drm: allow to use mmuless SoC")
Signed-off-by: Benjamin Gaignard <benjamin.gaignard@linaro.org>
Cc: Arnd Bergmann <arnd@arndb.de>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
---
 drivers/gpu/drm/Kconfig | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Daniel Vetter Jan. 12, 2017, 9:55 a.m. | #1
On Thu, Jan 12, 2017 at 09:57:36AM +0100, Benjamin Gaignard wrote:
> DRM_VM and DRM_LEGACY shouldn't be selected if MMU isn't set.
> 
> Fixes: 62a0d98a188c ("drm: allow to use mmuless SoC")
> Signed-off-by: Benjamin Gaignard <benjamin.gaignard@linaro.org>
> Cc: Arnd Bergmann <arnd@arndb.de>
> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>

Let's see how much we're going to anger Kconfig with this one :-)

Thanks, Daniel

> ---
>  drivers/gpu/drm/Kconfig | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/Kconfig b/drivers/gpu/drm/Kconfig
> index 6f3f9e6..90bc65d 100644
> --- a/drivers/gpu/drm/Kconfig
> +++ b/drivers/gpu/drm/Kconfig
> @@ -138,7 +138,7 @@ config DRM_KMS_CMA_HELPER
>  
>  config DRM_VM
>  	bool
> -	depends on DRM
> +	depends on DRM && MMU
>  
>  source "drivers/gpu/drm/i2c/Kconfig"
>  
> @@ -267,7 +267,7 @@ source "drivers/gpu/drm/meson/Kconfig"
>  
>  menuconfig DRM_LEGACY
>  	bool "Enable legacy drivers (DANGEROUS)"
> -	depends on DRM
> +	depends on DRM && MMU
>  	select DRM_VM
>  	help
>  	  Enable legacy DRI1 drivers. Those drivers expose unsafe and dangerous
> -- 
> 1.9.1
>

Patch

diff --git a/drivers/gpu/drm/Kconfig b/drivers/gpu/drm/Kconfig
index 6f3f9e6..90bc65d 100644
--- a/drivers/gpu/drm/Kconfig
+++ b/drivers/gpu/drm/Kconfig
@@ -138,7 +138,7 @@  config DRM_KMS_CMA_HELPER
 
 config DRM_VM
 	bool
-	depends on DRM
+	depends on DRM && MMU
 
 source "drivers/gpu/drm/i2c/Kconfig"
 
@@ -267,7 +267,7 @@  source "drivers/gpu/drm/meson/Kconfig"
 
 menuconfig DRM_LEGACY
 	bool "Enable legacy drivers (DANGEROUS)"
-	depends on DRM
+	depends on DRM && MMU
 	select DRM_VM
 	help
 	  Enable legacy DRI1 drivers. Those drivers expose unsafe and dangerous