qemu: Inherit pythonnative

Message ID 20170210045853.9043-1-raj.khem@gmail.com
State New
Headers show

Commit Message

Khem Raj Feb. 10, 2017, 4:58 a.m.
On buildhosts where default python has switched to using python3
qemu-native fails configure like this

| ERROR: Cannot use 'python', Python 2.6 or later is required.
|        Note that Python 3 or later is not yet supported.
|        Use --python=/path/to/python to specify a supported Python.
|

inheriting pythonnative makes sure that a usable python2 is always
available.

Signed-off-by: Khem Raj <raj.khem@gmail.com>

---
 meta/recipes-devtools/qemu/qemu.inc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.11.1

-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Comments

Ross Burton Feb. 10, 2017, 9:05 a.m. | #1
On 10 February 2017 at 04:58, Khem Raj <raj.khem@gmail.com> wrote:

> On buildhosts where default python has switched to using python3

> qemu-native fails configure like this

>

> | ERROR: Cannot use 'python', Python 2.6 or later is required.

> |        Note that Python 3 or later is not yet supported.

> |        Use --python=/path/to/python to specify a supported Python.

>


Build hosts where /usr/bin/python is Python3 are Doing It Wrong, and Python
upstream says don't do that.

Many other recipes depend on /usr/bin/python existing, so I'm not sure we
want to start building our own Python so early in the build just yet,
especially as we're trying to move away from Py2.  Can we not just list
python2 as a host dependency (to be honest, I thought it already was).

Ross
-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Patch hide | download patch | download mbox

diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index ef5d75c450..50f53f0de1 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -6,7 +6,7 @@  RDEPENDS_${PN}_class-target += "bash"
 RDEPENDS_${PN}-ptest = "bash make"
 
 require qemu-targets.inc
-inherit autotools pkgconfig ptest
+inherit autotools pkgconfig ptest pythonnative
 BBCLASSEXTEND = "native nativesdk"
 
 # QEMU_TARGETS is overridable variable