[1/5] travis: switch to ubuntu trusty

Message ID 20170214203202.13342-2-maxim.uvarov@linaro.org
State New
Headers show
Series
  • various travis updates
Related show

Commit Message

Maxim Uvarov Feb. 14, 2017, 8:31 p.m.
ubuntu trusty has updated doxygen 1.8.4 which is the same
stable version 1.8 which is described in DEPENDANCIES file.
Now doxygen do not generate any warnings. Compiler version
stays the same 4.8 for gcc.

Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>

---
 .travis.yml | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

-- 
2.11.0.295.gd7dffce

Comments

Mike Holmes Feb. 16, 2017, 4:11 p.m. | #1
On 14 February 2017 at 15:31, Maxim Uvarov <maxim.uvarov@linaro.org> wrote:

> ubuntu trusty has updated doxygen 1.8.4 which is the same

> stable version 1.8 which is described in DEPENDANCIES file.

> Now doxygen do not generate any warnings. Compiler version

> stays the same 4.8 for gcc.

>

> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>

>


Reviewed-by: Mike Holmes <mike.holmes@linaro.org>



> ---

>  .travis.yml | 8 +++++---

>  1 file changed, 5 insertions(+), 3 deletions(-)

>

> diff --git a/.travis.yml b/.travis.yml

> index e29233ec..a2e0a46a 100644

> --- a/.travis.yml

> +++ b/.travis.yml

> @@ -9,6 +9,7 @@

>

>  language: c

>  sudo: required

> +dist: trusty

>  env:

>    global:

>      # COVERITY_SCAN_TOKEN

> @@ -35,13 +36,13 @@ env:

>

>  matrix:

>    include:

> -    - compiler: gcc-4.8

> +    - compiler: gcc

>        addons:

>          apt:

>            sources:

>              - ubuntu-toolchain-r-test

>            packages:

> -            - gcc-4.8

> +            - gcc

>        env: MY_CF="-O0 -coverage" MY_LDF="--coverage" DOCOV=1

>      - compiler: clang

>        addons:

> @@ -62,6 +63,7 @@ before_install:

>          - PATH=${PATH//:\.\/node_modules\/\.bin/}

>

>  #       Install cunit for the validation tests because distro version is

> too old and fails C99 compile

> +        - sudo apt-get remove libcunit1-dev libcunit1

>          - export CUNIT_VERSION=2.1-3

>          - curl -sSOL http://sourceforge.net/project

> s/cunit/files/CUnit/${CUNIT_VERSION}/CUnit-${CUNIT_VERSION}.tar.bz2

>          - tar -jxf *.bz2

> @@ -125,7 +127,7 @@ script:

>          - sudo rm -rf $KSRC

>

>  after_success:

> -  - if [ -n "$DOCOV" ]; then find . -type f -iname '*.[ch]' -not -path

> ".git/*" -execdir gcov-4.8 {} \; ; bash <(curl -s https://codecov.io/bash)

> -X coveragepy; fi

> +  - if [ -n "$DOCOV" ]; then find . -type f -iname '*.[ch]' -not -path

> ".git/*" -execdir gcov {} \; ; bash <(curl -s https://codecov.io/bash) -X

> coveragepy; fi

>

>  addons:

>      coverity_scan:

> --

> 2.11.0.295.gd7dffce

>

>



-- 
Mike Holmes
Program Manager - Linaro Networking Group
Linaro.org <http://www.linaro.org/> *│ *Open source software for ARM SoCs
"Work should be fun and collaborative, the rest follows"

Patch hide | download patch | download mbox

diff --git a/.travis.yml b/.travis.yml
index e29233ec..a2e0a46a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,6 +9,7 @@ 
 
 language: c
 sudo: required
+dist: trusty
 env:
   global:
     # COVERITY_SCAN_TOKEN
@@ -35,13 +36,13 @@  env:
 
 matrix:
   include:
-    - compiler: gcc-4.8
+    - compiler: gcc
       addons:
         apt:
           sources:
             - ubuntu-toolchain-r-test
           packages:
-            - gcc-4.8
+            - gcc
       env: MY_CF="-O0 -coverage" MY_LDF="--coverage" DOCOV=1
     - compiler: clang
       addons:
@@ -62,6 +63,7 @@  before_install:
         - PATH=${PATH//:\.\/node_modules\/\.bin/}
 
 #       Install cunit for the validation tests because distro version is too old and fails C99 compile
+        - sudo apt-get remove libcunit1-dev libcunit1
         - export CUNIT_VERSION=2.1-3
         - curl -sSOL http://sourceforge.net/projects/cunit/files/CUnit/${CUNIT_VERSION}/CUnit-${CUNIT_VERSION}.tar.bz2
         - tar -jxf *.bz2
@@ -125,7 +127,7 @@  script:
         - sudo rm -rf $KSRC
 
 after_success:
-  - if [ -n "$DOCOV" ]; then find . -type f -iname '*.[ch]' -not -path ".git/*" -execdir gcov-4.8 {} \; ; bash <(curl -s https://codecov.io/bash) -X coveragepy; fi
+  - if [ -n "$DOCOV" ]; then find . -type f -iname '*.[ch]' -not -path ".git/*" -execdir gcov {} \; ; bash <(curl -s https://codecov.io/bash) -X coveragepy; fi
 
 addons:
     coverity_scan: