[2/5] travis: clang 3.8

Message ID 20170214203202.13342-3-maxim.uvarov@linaro.org
State New
Headers show
Series
  • various travis updates
Related show

Commit Message

Maxim Uvarov Feb. 14, 2017, 8:31 p.m.
Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>

---
 .travis.yml | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

-- 
2.11.0.295.gd7dffce

Comments

Mike Holmes Feb. 16, 2017, 4:12 p.m. | #1
On 14 February 2017 at 15:31, Maxim Uvarov <maxim.uvarov@linaro.org> wrote:

> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>

>


Reviewed-by: Mike Holmes <mike.holmes@linaro.org>



> ---

>  .travis.yml | 6 +++++-

>  1 file changed, 5 insertions(+), 1 deletion(-)

>

> diff --git a/.travis.yml b/.travis.yml

> index a2e0a46a..9e7471c2 100644

> --- a/.travis.yml

> +++ b/.travis.yml

> @@ -47,8 +47,11 @@ matrix:

>      - compiler: clang

>        addons:

>          apt:

> +          sources:

> +            - ubuntu-toolchain-r-test

> +            - llvm-toolchain-precise-3.8

>            packages:

> -            - clang

> +            - clang-3.8

>

>  before_install:

>          - echo 1000 | sudo tee /proc/sys/vm/nr_hugepages

> @@ -61,6 +64,7 @@ before_install:

>          - sudo pip install coverage

>          - gem install asciidoctor

>          - PATH=${PATH//:\.\/node_modules\/\.bin/}

> +        - if [ "$CC" = "clang" ]; then export CXX="clang++-3.8"

> CC="clang-3.8" LD="clang-3.8"; fi

>

>  #       Install cunit for the validation tests because distro version is

> too old and fails C99 compile

>          - sudo apt-get remove libcunit1-dev libcunit1

> --

> 2.11.0.295.gd7dffce

>

>



-- 
Mike Holmes
Program Manager - Linaro Networking Group
Linaro.org <http://www.linaro.org/> *│ *Open source software for ARM SoCs
"Work should be fun and collaborative, the rest follows"

Patch hide | download patch | download mbox

diff --git a/.travis.yml b/.travis.yml
index a2e0a46a..9e7471c2 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -47,8 +47,11 @@  matrix:
     - compiler: clang
       addons:
         apt:
+          sources:
+            - ubuntu-toolchain-r-test
+            - llvm-toolchain-precise-3.8
           packages:
-            - clang
+            - clang-3.8
 
 before_install:
         - echo 1000 | sudo tee /proc/sys/vm/nr_hugepages
@@ -61,6 +64,7 @@  before_install:
         - sudo pip install coverage
         - gem install asciidoctor
         - PATH=${PATH//:\.\/node_modules\/\.bin/}
+        - if [ "$CC" = "clang" ]; then export CXX="clang++-3.8" CC="clang-3.8" LD="clang-3.8"; fi
 
 #       Install cunit for the validation tests because distro version is too old and fails C99 compile
         - sudo apt-get remove libcunit1-dev libcunit1