mbox series

[v3,0/8] Fix v4l2-compliance errors

Message ID 20210312124830.1344255-1-ribalda@chromium.org
Headers show
Series Fix v4l2-compliance errors | expand

Message

Ricardo Ribalda March 12, 2021, 12:48 p.m. UTC
In my computer I am getting this output for

v4l2-compliance -m /dev/media0 -a -f
Total for uvcvideo device /dev/media0: 8, Succeeded: 6, Failed: 2, Warnings: 0
Total for uvcvideo device /dev/video0: 54, Succeeded: 50, Failed: 4, Warnings: 2
Total for uvcvideo device /dev/video1: 46, Succeeded: 46, Failed: 0, Warnings: 0
Grand Total for uvcvideo device /dev/media0: 108, Succeeded: 102,
Failed: 6, Warnings: 2

After fixing all of them we go down to:

Total for uvcvideo device /dev/media0: 8, Succeeded: 8, Failed: 0, Warnings: 0
Total for uvcvideo device /dev/video0: 54, Succeeded: 54, Failed: 0, Warnings: 9
Total for uvcvideo device /dev/video1: 46, Succeeded: 46, Failed: 0, Warnings: 0
Grand Total for uvcvideo device /dev/media0: 108, Succeeded: 108,
Failed: 0, Warnings: 9

We are still not compliant with v4l2-compliance -s:

Streaming ioctls:
        test read/write: OK (Not Supported)
        test blocking wait: OK
                fail: v4l2-test-buffers.cpp(1265):
node->streamon(q.g_type()) != EINVAL
        test MMAP (no poll): FAIL
                fail: v4l2-test-buffers.cpp(1265):
node->streamon(q.g_type()) != EINVAL
        test MMAP (select): FAIL
                fail: v4l2-test-buffers.cpp(1265):
node->streamon(q.g_type()) != EINVAL
        test MMAP (epoll): FAIL

But fixing that will probably require a lot of changes in the driver
that are already implemented in the vb2 helpers. It is better to
continue Hans work on that:
https://git.linuxtv.org/hverkuil/media_tree.git/commit/?h=uvc-4.19&id=a6a0a05f643521d29a4c1e551b0be73ce66b7108

Changelog v2 (Thanks to Hans and Laurent)

- Reimplement the CTRL_CLASS as a patch on queryctl
- Do not return -EIO for case 8
- Handle request bug and which_def multiclass in core

Hans Verkuil (1):
  uvc: use vb2 ioctl and fop helpers

Ricardo Ribalda (7):
  media: v4l2-ioctl: Fix check_ext_ctrls
  media: uvcvideo: Set capability in s_param
  media: uvcvideo: Return -EIO for control errors
  media: uvcvideo: set error_idx to count on EACCESS
  media: uvcvideo: refactor __uvc_ctrl_add_mapping
  media: uvcvideo: Add support for V4L2_CTRL_TYPE_CTRL_CLASS
  media: uvcvideo: Set a different name for the metadata entity

 drivers/media/usb/uvc/uvc_ctrl.c     | 137 +++++++++++--
 drivers/media/usb/uvc/uvc_driver.c   |  36 +++-
 drivers/media/usb/uvc/uvc_metadata.c |   8 +-
 drivers/media/usb/uvc/uvc_queue.c    | 131 -------------
 drivers/media/usb/uvc/uvc_v4l2.c     | 280 +++------------------------
 drivers/media/usb/uvc/uvc_video.c    |   5 +
 drivers/media/usb/uvc/uvcvideo.h     |  34 +---
 drivers/media/v4l2-core/v4l2-ioctl.c |  25 ++-
 8 files changed, 206 insertions(+), 450 deletions(-)

Comments

Laurent Pinchart March 12, 2021, 10:27 p.m. UTC | #1
Hi Ricardo,

Thank you for the patch.

On Fri, Mar 12, 2021 at 01:48:29PM +0100, Ricardo Ribalda wrote:
> All the entities must have a unique name. And now that we are at it, we
> append the entity->id to the name to avoid collisions on multi-chain
> devices.
> 
> Fixes v4l2-compliance:
> Media Controller ioctls:
>                 fail: v4l2-test-media.cpp(205): v2_entity_names_set.find(key) != v2_entity_names_set.end()
>         test MEDIA_IOC_G_TOPOLOGY: FAIL
>                 fail: v4l2-test-media.cpp(394): num_data_links != num_links
> 	test MEDIA_IOC_ENUM_ENTITIES/LINKS: FAIL
> 
> Signed-off-by: Ricardo Ribalda <ribalda@chromium.org>
> ---
>  drivers/media/usb/uvc/uvc_driver.c | 21 ++++++++++++++++++++-
>  1 file changed, 20 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/media/usb/uvc/uvc_driver.c b/drivers/media/usb/uvc/uvc_driver.c
> index 35873cf2773d..6c928e708615 100644
> --- a/drivers/media/usb/uvc/uvc_driver.c
> +++ b/drivers/media/usb/uvc/uvc_driver.c
> @@ -2154,6 +2154,18 @@ static void uvc_unregister_video(struct uvc_device *dev)
>  #endif
>  }
>  
> +static int uvc_oterm_id(struct uvc_video_chain *chain)
> +{
> +	struct uvc_entity *entity;
> +
> +	list_for_each_entry(entity, &chain->entities, chain) {
> +		if (UVC_ENTITY_IS_OTERM(entity))
> +			return entity->id;

It can also be an ITERM for output devices. You can drop this function
and use stream>header.bTerminalLink below (see uvc_stream_by_id() and
its usage in uvc_register_terms()).

> +	}
> +
> +	return -1;
> +}
> +
>  int uvc_register_video_device(struct uvc_device *dev,
>  			      struct uvc_streaming *stream,
>  			      struct video_device *vdev,
> @@ -2162,6 +2174,8 @@ int uvc_register_video_device(struct uvc_device *dev,
>  			      const struct v4l2_file_operations *fops,
>  			      const struct v4l2_ioctl_ops *ioctl_ops)
>  {
> +	char prefix[sizeof(vdev->name) - 9];
> +	const char *suffix;
>  	int ret;
>  
>  	/* Initialize the video buffers queue. */
> @@ -2190,16 +2204,21 @@ int uvc_register_video_device(struct uvc_device *dev,
>  	case V4L2_BUF_TYPE_VIDEO_CAPTURE:
>  	default:
>  		vdev->device_caps = V4L2_CAP_VIDEO_CAPTURE | V4L2_CAP_STREAMING;
> +		suffix = "video";
>  		break;
>  	case V4L2_BUF_TYPE_VIDEO_OUTPUT:
>  		vdev->device_caps = V4L2_CAP_VIDEO_OUTPUT | V4L2_CAP_STREAMING;
> +		suffix = "out";

I wonder if these two should be video-cap and video-out (or vid-cap and
vid-out if you want to shorten them) ?

>  		break;
>  	case V4L2_BUF_TYPE_META_CAPTURE:
>  		vdev->device_caps = V4L2_CAP_META_CAPTURE | V4L2_CAP_STREAMING;
> +		suffix = "meta";
>  		break;
>  	}
>  
> -	strscpy(vdev->name, dev->name, sizeof(vdev->name));
> +	strscpy(prefix, dev->name, sizeof(prefix));
> +	snprintf(vdev->name, sizeof(vdev->name), "%s-%d %s", prefix,

The unit ID is never negative, so %u ?

> +		 uvc_oterm_id(stream->chain), suffix);

Truncating the device name at the beginning of the video node name isn't
very nice :-S How about the following ?

	snprintf(vdev->name, sizeof(vdev->name), "%s-%u (%s)", type_name,
		 uvc_oterm_id(stream->chain), dev->name);

with the suffix variable renamed to type_name ?

Thinking some more about it, vdev->name serves two purposes in the
driver: creating the entity name, and reporting the card name in
querycap. The former is done in the V4L2 core, which uses vdev->name
as-is. In this context, we con't need to add dev->name, it would be
redundant as the media controller device already reports it. The latter
is done in uvc_ioctl_querycap(). How about dropping dev->name from
vdev->name, and modifying uvc_ioctl_querycap() to use dev->name instead
of cap->card ?

>  
>  	/*
>  	 * Set the driver data before calling video_register_device, otherwise
Ricardo Ribalda Delgado March 12, 2021, 11:17 p.m. UTC | #2
HI Laurent

Thanks for the review

On Fri, Mar 12, 2021 at 11:30 PM Laurent Pinchart
<laurent.pinchart@ideasonboard.com> wrote:
>
> Hi Ricardo,
>
> Thank you for the patch.
>
> On Fri, Mar 12, 2021 at 01:48:29PM +0100, Ricardo Ribalda wrote:
> > All the entities must have a unique name. And now that we are at it, we
> > append the entity->id to the name to avoid collisions on multi-chain
> > devices.
> >
> > Fixes v4l2-compliance:
> > Media Controller ioctls:
> >                 fail: v4l2-test-media.cpp(205): v2_entity_names_set.find(key) != v2_entity_names_set.end()
> >         test MEDIA_IOC_G_TOPOLOGY: FAIL
> >                 fail: v4l2-test-media.cpp(394): num_data_links != num_links
> >       test MEDIA_IOC_ENUM_ENTITIES/LINKS: FAIL
> >
> > Signed-off-by: Ricardo Ribalda <ribalda@chromium.org>
> > ---
> >  drivers/media/usb/uvc/uvc_driver.c | 21 ++++++++++++++++++++-
> >  1 file changed, 20 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/media/usb/uvc/uvc_driver.c b/drivers/media/usb/uvc/uvc_driver.c
> > index 35873cf2773d..6c928e708615 100644
> > --- a/drivers/media/usb/uvc/uvc_driver.c
> > +++ b/drivers/media/usb/uvc/uvc_driver.c
> > @@ -2154,6 +2154,18 @@ static void uvc_unregister_video(struct uvc_device *dev)
> >  #endif
> >  }
> >
> > +static int uvc_oterm_id(struct uvc_video_chain *chain)
> > +{
> > +     struct uvc_entity *entity;
> > +
> > +     list_for_each_entry(entity, &chain->entities, chain) {
> > +             if (UVC_ENTITY_IS_OTERM(entity))
> > +                     return entity->id;
>
> It can also be an ITERM for output devices. You can drop this function
> and use stream>header.bTerminalLink below (see uvc_stream_by_id() and
> its usage in uvc_register_terms()).
>
> > +     }
> > +
> > +     return -1;
> > +}
> > +
> >  int uvc_register_video_device(struct uvc_device *dev,
> >                             struct uvc_streaming *stream,
> >                             struct video_device *vdev,
> > @@ -2162,6 +2174,8 @@ int uvc_register_video_device(struct uvc_device *dev,
> >                             const struct v4l2_file_operations *fops,
> >                             const struct v4l2_ioctl_ops *ioctl_ops)
> >  {
> > +     char prefix[sizeof(vdev->name) - 9];
> > +     const char *suffix;
> >       int ret;
> >
> >       /* Initialize the video buffers queue. */
> > @@ -2190,16 +2204,21 @@ int uvc_register_video_device(struct uvc_device *dev,
> >       case V4L2_BUF_TYPE_VIDEO_CAPTURE:
> >       default:
> >               vdev->device_caps = V4L2_CAP_VIDEO_CAPTURE | V4L2_CAP_STREAMING;
> > +             suffix = "video";
> >               break;
> >       case V4L2_BUF_TYPE_VIDEO_OUTPUT:
> >               vdev->device_caps = V4L2_CAP_VIDEO_OUTPUT | V4L2_CAP_STREAMING;
> > +             suffix = "out";
>
> I wonder if these two should be video-cap and video-out (or vid-cap and
> vid-out if you want to shorten them) ?
>
> >               break;
> >       case V4L2_BUF_TYPE_META_CAPTURE:
> >               vdev->device_caps = V4L2_CAP_META_CAPTURE | V4L2_CAP_STREAMING;
> > +             suffix = "meta";
> >               break;
> >       }
> >
> > -     strscpy(vdev->name, dev->name, sizeof(vdev->name));
> > +     strscpy(prefix, dev->name, sizeof(prefix));
> > +     snprintf(vdev->name, sizeof(vdev->name), "%s-%d %s", prefix,
>
> The unit ID is never negative, so %u ?
>
> > +              uvc_oterm_id(stream->chain), suffix);
>
> Truncating the device name at the beginning of the video node name isn't
> very nice :-S How about the following ?
>
>         snprintf(vdev->name, sizeof(vdev->name), "%s-%u (%s)", type_name,
>                  uvc_oterm_id(stream->chain), dev->name);
>
> with the suffix variable renamed to type_name ?
>
> Thinking some more about it, vdev->name serves two purposes in the
> driver: creating the entity name, and reporting the card name in
> querycap. The former is done in the V4L2 core, which uses vdev->name
> as-is. In this context, we con't need to add dev->name, it would be
> redundant as the media controller device already reports it. The latter
> is done in uvc_ioctl_querycap(). How about dropping dev->name from
> vdev->name, and modifying uvc_ioctl_querycap() to use dev->name instead
> of cap->card ?
>

Something like ?
https://git.kernel.org/pub/scm/linux/kernel/git/ribalda/linux.git/commit/?h=uvc-compliance-v4&id=d4f7363455837116268152c96bf4b78d9761ad1e
https://git.kernel.org/pub/scm/linux/kernel/git/ribalda/linux.git/commit/?h=uvc-compliance-v4&id=ee3916f12b30f56c03d5622ba8a599b9c610a055

I need to work on the V4L2_CTRL_FLAG_GRABBED issue and then I will
send the whole v4 series that can pass all the v4l2-compliance test :)

Thanks!

> >
> >       /*
> >        * Set the driver data before calling video_register_device, otherwise
>
> --
> Regards,
>
> Laurent Pinchart
Ricardo Ribalda Delgado March 12, 2021, 11:47 p.m. UTC | #3
Hi Laurent

Thanks!
On Sat, Mar 13, 2021 at 12:29 AM Laurent Pinchart
<laurent.pinchart@ideasonboard.com> wrote:
>
> Hi Ricardo,
>
> On Sat, Mar 13, 2021 at 12:17:50AM +0100, Ricardo Ribalda Delgado wrote:
> > On Fri, Mar 12, 2021 at 11:30 PM Laurent Pinchart wrote:
> > > On Fri, Mar 12, 2021 at 01:48:29PM +0100, Ricardo Ribalda wrote:
> > > > All the entities must have a unique name. And now that we are at it, we
> > > > append the entity->id to the name to avoid collisions on multi-chain
> > > > devices.
> > > >
> > > > Fixes v4l2-compliance:
> > > > Media Controller ioctls:
> > > >                 fail: v4l2-test-media.cpp(205): v2_entity_names_set.find(key) != v2_entity_names_set.end()
> > > >         test MEDIA_IOC_G_TOPOLOGY: FAIL
> > > >                 fail: v4l2-test-media.cpp(394): num_data_links != num_links
> > > >       test MEDIA_IOC_ENUM_ENTITIES/LINKS: FAIL
> > > >
> > > > Signed-off-by: Ricardo Ribalda <ribalda@chromium.org>
> > > > ---
> > > >  drivers/media/usb/uvc/uvc_driver.c | 21 ++++++++++++++++++++-
> > > >  1 file changed, 20 insertions(+), 1 deletion(-)
> > > >
> > > > diff --git a/drivers/media/usb/uvc/uvc_driver.c b/drivers/media/usb/uvc/uvc_driver.c
> > > > index 35873cf2773d..6c928e708615 100644
> > > > --- a/drivers/media/usb/uvc/uvc_driver.c
> > > > +++ b/drivers/media/usb/uvc/uvc_driver.c
> > > > @@ -2154,6 +2154,18 @@ static void uvc_unregister_video(struct uvc_device *dev)
> > > >  #endif
> > > >  }
> > > >
> > > > +static int uvc_oterm_id(struct uvc_video_chain *chain)
> > > > +{
> > > > +     struct uvc_entity *entity;
> > > > +
> > > > +     list_for_each_entry(entity, &chain->entities, chain) {
> > > > +             if (UVC_ENTITY_IS_OTERM(entity))
> > > > +                     return entity->id;
> > >
> > > It can also be an ITERM for output devices. You can drop this function
> > > and use stream>header.bTerminalLink below (see uvc_stream_by_id() and
> > > its usage in uvc_register_terms()).
> > >
> > > > +     }
> > > > +
> > > > +     return -1;
> > > > +}
> > > > +
> > > >  int uvc_register_video_device(struct uvc_device *dev,
> > > >                             struct uvc_streaming *stream,
> > > >                             struct video_device *vdev,
> > > > @@ -2162,6 +2174,8 @@ int uvc_register_video_device(struct uvc_device *dev,
> > > >                             const struct v4l2_file_operations *fops,
> > > >                             const struct v4l2_ioctl_ops *ioctl_ops)
> > > >  {
> > > > +     char prefix[sizeof(vdev->name) - 9];
> > > > +     const char *suffix;
> > > >       int ret;
> > > >
> > > >       /* Initialize the video buffers queue. */
> > > > @@ -2190,16 +2204,21 @@ int uvc_register_video_device(struct uvc_device *dev,
> > > >       case V4L2_BUF_TYPE_VIDEO_CAPTURE:
> > > >       default:
> > > >               vdev->device_caps = V4L2_CAP_VIDEO_CAPTURE | V4L2_CAP_STREAMING;
> > > > +             suffix = "video";
> > > >               break;
> > > >       case V4L2_BUF_TYPE_VIDEO_OUTPUT:
> > > >               vdev->device_caps = V4L2_CAP_VIDEO_OUTPUT | V4L2_CAP_STREAMING;
> > > > +             suffix = "out";
> > >
> > > I wonder if these two should be video-cap and video-out (or vid-cap and
> > > vid-out if you want to shorten them) ?
> > >
> > > >               break;
> > > >       case V4L2_BUF_TYPE_META_CAPTURE:
> > > >               vdev->device_caps = V4L2_CAP_META_CAPTURE | V4L2_CAP_STREAMING;
> > > > +             suffix = "meta";
> > > >               break;
> > > >       }
> > > >
> > > > -     strscpy(vdev->name, dev->name, sizeof(vdev->name));
> > > > +     strscpy(prefix, dev->name, sizeof(prefix));
> > > > +     snprintf(vdev->name, sizeof(vdev->name), "%s-%d %s", prefix,
> > >
> > > The unit ID is never negative, so %u ?
> > >
> > > > +              uvc_oterm_id(stream->chain), suffix);
> > >
> > > Truncating the device name at the beginning of the video node name isn't
> > > very nice :-S How about the following ?
> > >
> > >         snprintf(vdev->name, sizeof(vdev->name), "%s-%u (%s)", type_name,
> > >                  uvc_oterm_id(stream->chain), dev->name);
> > >
> > > with the suffix variable renamed to type_name ?
> > >
> > > Thinking some more about it, vdev->name serves two purposes in the
> > > driver: creating the entity name, and reporting the card name in
> > > querycap. The former is done in the V4L2 core, which uses vdev->name
> > > as-is. In this context, we con't need to add dev->name, it would be
> > > redundant as the media controller device already reports it. The latter
> > > is done in uvc_ioctl_querycap(). How about dropping dev->name from
> > > vdev->name, and modifying uvc_ioctl_querycap() to use dev->name instead
> > > of cap->card ?
> > >
> >
> > Something like ?
> > https://git.kernel.org/pub/scm/linux/kernel/git/ribalda/linux.git/commit/?h=uvc-compliance-v4&id=d4f7363455837116268152c96bf4b78d9761ad1e
>
> I would have moved the sprintf() after the switch/case, but otherwise
> it's the idea.

https://git.kernel.org/pub/scm/linux/kernel/git/ribalda/linux.git/commit/?h=uvc-compliance-v4&id=fe287f9d764457f5bcd48780b99e54df161f33f6

Yep, it looks better

>
> > https://git.kernel.org/pub/scm/linux/kernel/git/ribalda/linux.git/commit/?h=uvc-compliance-v4&id=ee3916f12b30f56c03d5622ba8a599b9c610a055
>
> Looks good.
>
> > I need to work on the V4L2_CTRL_FLAG_GRABBED issue and then I will
> > send the whole v4 series that can pass all the v4l2-compliance test :)
> >
> > > >
> > > >       /*
> > > >        * Set the driver data before calling video_register_device, otherwise
>
> --
> Regards,
>
> Laurent Pinchart