mbox series

[v1,0/3] spi: CS code, variables and comments clarification

Message ID 20240306160114.3471398-1-andriy.shevchenko@linux.intel.com
Headers show
Series spi: CS code, variables and comments clarification | expand

Message

Andy Shevchenko March 6, 2024, 3:59 p.m. UTC
There are a few duplicated code pieces, inconsitent types and comments
regarding to Chip Select pins. Refactor and clarify that.

Andy Shevchenko (3):
  spi: Exctract spi_set_all_cs_unused() helper
  spi: Exctract spi_dev_check_cs() helper
  spi: Fix multiple issues with Chip Select variables and comments

 drivers/spi/spi.c       | 173 +++++++++++++++++-----------------------
 include/linux/spi/spi.h |  15 ++--
 2 files changed, 82 insertions(+), 106 deletions(-)

Comments

Mark Brown March 6, 2024, 6:08 p.m. UTC | #1
On Wed, Mar 06, 2024 at 05:59:42PM +0200, Andy Shevchenko wrote:
> There are the following issues with the current code:
> - inconsistent use of 0xFF and -1 for invalid chip select pin
> - inconsistent plain or BIT() use
> - wrong types used for last_cs_* fields
> - wrong multi-line comment style
> - misleading or hard-to-understand comments
> 
> Fix all of these here.

Please don't do this, as covered in submitting-patches.rst submit one
change per patch.  This makes it much easier to review things.
Andy Shevchenko March 6, 2024, 8:12 p.m. UTC | #2
On Wed, Mar 06, 2024 at 06:08:43PM +0000, Mark Brown wrote:
> On Wed, Mar 06, 2024 at 05:59:42PM +0200, Andy Shevchenko wrote:
> > There are the following issues with the current code:
> > - inconsistent use of 0xFF and -1 for invalid chip select pin
> > - inconsistent plain or BIT() use
> > - wrong types used for last_cs_* fields
> > - wrong multi-line comment style
> > - misleading or hard-to-understand comments
> > 
> > Fix all of these here.
> 
> Please don't do this, as covered in submitting-patches.rst submit one
> change per patch.  This makes it much easier to review things.

Fine by me, consider this patch as RFC to understand if we want to have this
or not in general. I will rework it, if the idea is acceptable.

If you are fine on the first two, perhaps they can be applied first.
Mark Brown March 6, 2024, 9:59 p.m. UTC | #3
On Wed, 06 Mar 2024 17:59:39 +0200, Andy Shevchenko wrote:
> There are a few duplicated code pieces, inconsitent types and comments
> regarding to Chip Select pins. Refactor and clarify that.
> 
> Andy Shevchenko (3):
>   spi: Exctract spi_set_all_cs_unused() helper
>   spi: Exctract spi_dev_check_cs() helper
>   spi: Fix multiple issues with Chip Select variables and comments
> 
> [...]

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/spi.git for-next

Thanks!

[1/3] spi: Exctract spi_set_all_cs_unused() helper
      commit: 5ee91605ad9ad363766a7ed13dc7d47f5102982a
[2/3] spi: Exctract spi_dev_check_cs() helper
      commit: 9086d0f23b7c292f162a828967975e29e97c0680

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark
Andy Shevchenko March 7, 2024, 3:08 p.m. UTC | #4
On Wed, Mar 06, 2024 at 10:12:06PM +0200, Andy Shevchenko wrote:
> On Wed, Mar 06, 2024 at 06:08:43PM +0000, Mark Brown wrote:
> > On Wed, Mar 06, 2024 at 05:59:42PM +0200, Andy Shevchenko wrote:
> > > There are the following issues with the current code:
> > > - inconsistent use of 0xFF and -1 for invalid chip select pin
> > > - inconsistent plain or BIT() use
> > > - wrong types used for last_cs_* fields
> > > - wrong multi-line comment style
> > > - misleading or hard-to-understand comments
> > > 
> > > Fix all of these here.
> > 
> > Please don't do this, as covered in submitting-patches.rst submit one
> > change per patch.  This makes it much easier to review things.
> 
> Fine by me, consider this patch as RFC to understand if we want to have this
> or not in general. I will rework it, if the idea is acceptable.

I have sent a new series where I split this to three patches (and excluded
the rest for now).