mbox series

[00/25] drm: Kirin driver cleanups to prep for Kirin960 support

Message ID 1556061656-1733-1-git-send-email-john.stultz@linaro.org
Headers show
Series drm: Kirin driver cleanups to prep for Kirin960 support | expand

Message

John Stultz April 23, 2019, 11:20 p.m. UTC
This patchset contains one fix (in the front, so its easier to
eventually backport), and a series of changes from YiPing to
refactor the kirin drm driver so that it can be used on both
kirin620 based devices (like the original HiKey board) as well
as kirin960 based devices (like the HiKey960 board).

The full kirin960 drm support is still being refactored, but as
this base kirin rework was getting to be substantial, I wanted
to send out the first chunk for some initial review, so that the
review burden wasn't overwhelming.

The full HiKey960 patch stack can be found here:
  https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP


Feedback would be greatly appreciated!

thanks
-john


Cc: YiPing Xu <xuyiping@hisilicon.com>
Cc: Xinliang Liu <z.liuxinliang@hisilicon.com>
Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: Xinwei Kong <kong.kongxinwei@hisilicon.com>
Cc: Chen Feng <puck.chen@hisilicon.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>

Da Lv (1):
  drm: kirin: Fix for hikey620 display offset problem

John Stultz (3):
  drm: kirin: Remove HISI_KIRIN_DW_DSI config option
  drm: kirin: Remove unreachable return
  drm: kirin: Move workqueue to ade_hw_ctx structure

Xu YiPing (21):
  drm: kirin: Remove uncessary parameter indirection
  drm: kirin: Remove out_format from ade_crtc
  drm: kirin: Rename ade_plane to kirin_plane
  drm: kirin: Rename ade_crtc to kirin_crtc
  drm: kirin: Dynamically allocate the hw_ctx
  drm: kirin: Move request irq handle in ade hw ctx alloc
  drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to
    kirin_drm_drv.h
  drm: kirin: Reanme dc_ops to kirin_drm_data
  drm: kirin: Move ade crtc/plane help functions to driver_data
  drm: kirin: Move channel formats to driver data
  drm: kirin: Move mode config function to driver_data
  drm: kirin: Move plane number and primay plane in driver data
  drm: kirin: Move config max_width and max_height to driver data
  drm: kirin: Move drm driver to driver data
  drm: kirin: Add register connect helper functions in drm init
  drm: kirin: Rename plane_init and crtc_init
  drm: kirin: Fix dev->driver_data setting
  drm: kirin: Make driver_data variable non-global
  drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data
  drm: kirin: Pass driver data to crtc init and plane init
  drm: kirin: Move ade drm init to kirin drm drv

 drivers/gpu/drm/hisilicon/kirin/Kconfig         |  10 +-
 drivers/gpu/drm/hisilicon/kirin/Makefile        |   4 +-
 drivers/gpu/drm/hisilicon/kirin/kirin_ade_reg.h |   6 +
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 354 ++++++++++--------------
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c | 253 ++++++++++++-----
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.h |  48 +++-
 6 files changed, 376 insertions(+), 299 deletions(-)

-- 
2.7.4

Comments

John Stultz April 24, 2019, 7:40 p.m. UTC | #1
On Wed, Apr 24, 2019 at 10:13 AM Sam Ravnborg <sam@ravnborg.org> wrote:
>

> Hi John.

>

> On Tue, Apr 23, 2019 at 04:20:31PM -0700, John Stultz wrote:

> > This patchset contains one fix (in the front, so its easier to

> > eventually backport), and a series of changes from YiPing to

> > refactor the kirin drm driver so that it can be used on both

> > kirin620 based devices (like the original HiKey board) as well

> > as kirin960 based devices (like the HiKey960 board).

> >

> > The full kirin960 drm support is still being refactored, but as

> > this base kirin rework was getting to be substantial, I wanted

> > to send out the first chunk for some initial review, so that the

> > review burden wasn't overwhelming.

> I have been through all 25 patches and it triggered a few minor

> comments here and there.

> I know nothing about the hisilicon driver but based on the fact

> that I know nothing about the driver you can give them all

> a (smallish)

> Reviewed-by: Sam Ravnborg <sam@ravnborg.org>

>

> I trust your judgement to decide the feedback you want to address and

> what to ignore.


Thanks again for your time and thoughts here! I really appreciate it!

> One request:

> Could you please in a follow-up patch kill the use of drmP.h.

> We want to get rid of it one day and three fewer users are one

> small step towards this goal.


I'll take a swing at this. Thanks!
-john
Sam Ravnborg April 24, 2019, 8:54 p.m. UTC | #2
Hi John.

On Tue, Apr 23, 2019 at 04:20:31PM -0700, John Stultz wrote:
> This patchset contains one fix (in the front, so its easier to

> eventually backport), and a series of changes from YiPing to

> refactor the kirin drm driver so that it can be used on both

> kirin620 based devices (like the original HiKey board) as well

> as kirin960 based devices (like the HiKey960 board).

> 

> The full kirin960 drm support is still being refactored, but as

> this base kirin rework was getting to be substantial, I wanted

> to send out the first chunk for some initial review, so that the

> review burden wasn't overwhelming.

> 

> The full HiKey960 patch stack can be found here:

>   https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP


On the mailing list we are missing patch 25/25 - I only realize now.

	Sam
John Stultz April 24, 2019, 9:02 p.m. UTC | #3
On Wed, Apr 24, 2019 at 1:54 PM Sam Ravnborg <sam@ravnborg.org> wrote:
>

> Hi John.

>

> On Tue, Apr 23, 2019 at 04:20:31PM -0700, John Stultz wrote:

> > This patchset contains one fix (in the front, so its easier to

> > eventually backport), and a series of changes from YiPing to

> > refactor the kirin drm driver so that it can be used on both

> > kirin620 based devices (like the original HiKey board) as well

> > as kirin960 based devices (like the HiKey960 board).

> >

> > The full kirin960 drm support is still being refactored, but as

> > this base kirin rework was getting to be substantial, I wanted

> > to send out the first chunk for some initial review, so that the

> > review burden wasn't overwhelming.

> >

> > The full HiKey960 patch stack can be found here:

> >   https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP

>

> On the mailing list we are missing patch 25/25 - I only realize now.


Oof. Somehow I didn't add my Cc: list to the commit message. Apologies!

You can find it here:
  https://lkml.org/lkml/2019/4/23/1140

thanks
-john