mbox series

[v5,00/27] Venus updates

Message ID 20180705130401.24315-1-stanimir.varbanov@linaro.org
Headers show
Series Venus updates | expand

Message

Stanimir Varbanov July 5, 2018, 1:03 p.m. UTC
Hi,

Changes since v4:
 * 02/27 re-write intbufs_alloc as suggested by Alex, and
   moved new structures in 03/27 where they are used
 * 11/27 exit early if error occur in vdec_runtime_suspend
   venc_runtime_suspend and avoid ORing ret variable
 * 12/27 fixed typo in patch description
 * added a const when declare ptype variable

Previous v4 can be found at https://lkml.org/lkml/2018/6/27/404

regards,
Stan

Stanimir Varbanov (27):
  venus: hfi_msgs: correct pointer increment
  venus: hfi: preparation to support venus 4xx
  venus: hfi: update sequence event to handle more properties
  venus: hfi_cmds: add set_properties for 4xx version
  venus: hfi: support session continue for 4xx version
  venus: hfi: handle buffer output2 type as well
  venus: hfi_venus: add halt AXI support for Venus 4xx
  venus: hfi_venus: fix suspend function for venus 3xx versions
  venus: hfi_venus: move set of default properties to core init
  venus: hfi_venus: add suspend functionality for Venus 4xx
  venus: core,helpers: add two more clocks found in Venus 4xx
  venus: hfi_parser: add common capability parser
  venus: helpers: rename a helper function and use buffer mode from caps
  venus: helpers: add a helper function to set dynamic buffer mode
  venus: helpers: add helper function to set actual buffer size
  venus: core: delete not used buffer mode flags
  venus: helpers: add buffer type argument to a helper
  venus: helpers: add a new helper to set raw format
  venus: helpers,vdec,venc: add helpers to set work mode and core usage
  venus: helpers: extend set_num_bufs helper with one more argument
  venus: helpers: add a helper to return opb buffer sizes
  venus: vdec: get required input buffers as well
  venus: vdec: a new function for output configuration
  venus: helpers: move frame size calculations on common place
  venus: implementing multi-stream support
  venus: core: add sdm845 DT compatible and resource data
  venus: add HEVC codec support

 .../devicetree/bindings/media/qcom,venus.txt       |   1 +
 drivers/media/platform/qcom/venus/Makefile         |   3 +-
 drivers/media/platform/qcom/venus/core.c           | 107 ++++
 drivers/media/platform/qcom/venus/core.h           | 100 ++--
 drivers/media/platform/qcom/venus/helpers.c        | 568 +++++++++++++++++++--
 drivers/media/platform/qcom/venus/helpers.h        |  23 +-
 drivers/media/platform/qcom/venus/hfi.c            |  12 +-
 drivers/media/platform/qcom/venus/hfi.h            |  10 +
 drivers/media/platform/qcom/venus/hfi_cmds.c       |  62 ++-
 drivers/media/platform/qcom/venus/hfi_helper.h     | 112 +++-
 drivers/media/platform/qcom/venus/hfi_msgs.c       | 407 +++------------
 drivers/media/platform/qcom/venus/hfi_parser.c     | 278 ++++++++++
 drivers/media/platform/qcom/venus/hfi_parser.h     |  45 ++
 drivers/media/platform/qcom/venus/hfi_venus.c      | 108 +++-
 drivers/media/platform/qcom/venus/hfi_venus_io.h   |  10 +
 drivers/media/platform/qcom/venus/vdec.c           | 326 +++++++-----
 drivers/media/platform/qcom/venus/venc.c           | 220 ++++----
 17 files changed, 1702 insertions(+), 690 deletions(-)
 create mode 100644 drivers/media/platform/qcom/venus/hfi_parser.c
 create mode 100644 drivers/media/platform/qcom/venus/hfi_parser.h

-- 
2.14.1

Comments

Hans Verkuil July 5, 2018, 2:08 p.m. UTC | #1
On 05/07/18 16:07, Tomasz Figa wrote:
> Hi Stanimir,

> 

> On Thu, Jul 5, 2018 at 10:05 PM Stanimir Varbanov

> <stanimir.varbanov@linaro.org> wrote:

>>

>> Hi,

>>

>> Changes since v4:

>>  * 02/27 re-write intbufs_alloc as suggested by Alex, and

>>    moved new structures in 03/27 where they are used

>>  * 11/27 exit early if error occur in vdec_runtime_suspend

>>    venc_runtime_suspend and avoid ORing ret variable

>>  * 12/27 fixed typo in patch description

>>  * added a const when declare ptype variable

>>

>> Previous v4 can be found at https://lkml.org/lkml/2018/6/27/404

> 

> Thanks for the patches!

> 

> Reviewed-by: Tomasz Figa <tfiga@chromium.org>


Are we waiting for anything else? Otherwise I plan to make a pull request for
this tomorrow.

Regards,

	Hans
Alexandre Courbot July 6, 2018, 3:55 a.m. UTC | #2
On Fri, Jul 6, 2018 at 12:00 AM Alexandre Courbot <acourbot@chromium.org> wrote:
>

> On Thu, Jul 5, 2018 at 11:52 PM Stanimir Varbanov

> <stanimir.varbanov@linaro.org> wrote:

> >

> > Hi,

> >

> > On 07/05/2018 05:08 PM, Hans Verkuil wrote:

> > > On 05/07/18 16:07, Tomasz Figa wrote:

> > >> Hi Stanimir,

> > >>

> > >> On Thu, Jul 5, 2018 at 10:05 PM Stanimir Varbanov

> > >> <stanimir.varbanov@linaro.org> wrote:

> > >>>

> > >>> Hi,

> > >>>

> > >>> Changes since v4:

> > >>>  * 02/27 re-write intbufs_alloc as suggested by Alex, and

> > >>>    moved new structures in 03/27 where they are used

> > >>>  * 11/27 exit early if error occur in vdec_runtime_suspend

> > >>>    venc_runtime_suspend and avoid ORing ret variable

> > >>>  * 12/27 fixed typo in patch description

> > >>>  * added a const when declare ptype variable

> > >>>

> > >>> Previous v4 can be found at https://lkml.org/lkml/2018/6/27/404

> > >>

> > >> Thanks for the patches!

> > >>

> > >> Reviewed-by: Tomasz Figa <tfiga@chromium.org>

> >

> > Thanks Tomasz!

> >

> > >

> > > Are we waiting for anything else? Otherwise I plan to make a pull request for

> > > this tomorrow.

> >

> > I think we are done.

>

> I would just like to give this one last test - will be done by tomorrow JST.


Confirmed my unit tests were still running with this version and had a
quick look at the changes.

The series,

Reviewed-by: Alexandre Courbot <acourbot@chromium.org>

Tested-by: Alexandre Courbot <acourbot@chromium.org>