Message ID | cover.1547458732.git.amit.kucheria@linaro.org |
---|---|
Headers | show |
Series | Thermal throttling for SDM845 | expand |
On Mon, Jan 14, 2019 at 3:57 PM Rafael J. Wysocki <rafael@kernel.org> wrote: > > On Mon, Jan 14, 2019 at 11:22 AM Amit Kucheria <amit.kucheria@linaro.org> wrote: > > > > Add support for thermal throttling on SDM845. > > > > We introduce a generic flag to be used by cpufreq drivers to tell the > > cpufreq core to auto-register a thermal cooling device. > > > > There are a few miscellaneous fixes to keep checkpatch happy. > > > > If this approach is acceptable I can send a series converting other cpufreq > > drivers to use this flag and get rid of driver code. > > > > Amit Kucheria (9): > > [ALREADY QUEUED] cpufreq: qcom-hw: Move to device_initcall > > drivers: thermal: of-thermal: Print name of device node with error > > drivers: cpufreq: Add thermal_cooling_device pointer to struct > > cpufreq_policy > > cpufreq: Add a flag to auto-register a cooling device > > cpufreq: Replace open-coded << with BIT() > > cpufreq: qcom-hw: Register as a cpufreq cooling device > > arm64: dts: sdm845: Increase alert trip point to 95 degrees > > arm64: dts: sdm845: wireup the thermal trip points to cpufreq > > thermal: cpu_cooling: Clarify error message > > > > arch/arm64/boot/dts/qcom/sdm845.dtsi | 193 +++++++++++++++++++++++---- > > drivers/cpufreq/cpufreq.c | 13 ++ > > drivers/cpufreq/qcom-cpufreq-hw.c | 5 +- > > drivers/thermal/cpu_cooling.c | 2 +- > > drivers/thermal/of-thermal.c | 4 +- > > include/linux/cpufreq.h | 34 +++-- > > 6 files changed, 210 insertions(+), 41 deletions(-) > > Would it be possible to split this series so as to put the cpufreq > patches separately? Sure, will send out another version.
Quoting Amit Kucheria (2019-01-14 02:21:08) > Add the CPUFREQ_AUTO_REGISTER_COOLING_DEV flag to allow the cpufreq core > to auto-register the driver as a cooling device. > > Signed-off-by: Amit Kucheria <amit.kucheria@linaro.org> > --- Reviewed-by: Stephen Boyd <swboyd@chromium.org>
On 14-01-19, 15:51, Amit Kucheria wrote:
> (Resent to allow people testing the series to test it easily)
Maybe just share your branch then, instead of sending this again ?
--
viresh