diff mbox series

[1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv

Message ID 20181210165243.5625-1-daniel.lezcano@linaro.org
State Superseded
Headers show
Series [1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv | expand

Commit Message

Daniel Lezcano Dec. 10, 2018, 4:52 p.m. UTC
In order to unify the names in this directory, let's rename the driver to be
prefixed with timer-*

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>

---
 drivers/clocksource/Makefile                         | 2 +-
 drivers/clocksource/{riscv_timer.c => timer-riscv.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/clocksource/{riscv_timer.c => timer-riscv.c} (100%)

-- 
2.17.1

Comments

Palmer Dabbelt Dec. 10, 2018, 5:45 p.m. UTC | #1
On Mon, 10 Dec 2018 08:52:38 PST (-0800), daniel.lezcano@linaro.org wrote:
> In order to unify the names in this directory, let's rename the driver to be

> prefixed with timer-*

>

> Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>

> ---

>  drivers/clocksource/Makefile                         | 2 +-

>  drivers/clocksource/{riscv_timer.c => timer-riscv.c} | 0

>  2 files changed, 1 insertion(+), 1 deletion(-)

>  rename drivers/clocksource/{riscv_timer.c => timer-riscv.c} (100%)

>

> diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile

> index dd9138104568..ddf697b29df9 100644

> --- a/drivers/clocksource/Makefile

> +++ b/drivers/clocksource/Makefile

> @@ -78,6 +78,6 @@ obj-$(CONFIG_H8300_TPU)			+= h8300_tpu.o

>  obj-$(CONFIG_CLKSRC_ST_LPC)		+= clksrc_st_lpc.o

>  obj-$(CONFIG_X86_NUMACHIP)		+= numachip.o

>  obj-$(CONFIG_ATCPIT100_TIMER)		+= timer-atcpit100.o

> -obj-$(CONFIG_RISCV_TIMER)		+= riscv_timer.o

> +obj-$(CONFIG_RISCV_TIMER)		+= timer-riscv.o

>  obj-$(CONFIG_CSKY_MP_TIMER)		+= timer-mp-csky.o

>  obj-$(CONFIG_GX6605S_TIMER)		+= timer-gx6605s.o

> diff --git a/drivers/clocksource/riscv_timer.c b/drivers/clocksource/timer-riscv.c

> similarity index 100%

> rename from drivers/clocksource/riscv_timer.c

> rename to drivers/clocksource/timer-riscv.c


Reviewed-by: Palmer Dabbelt <palmer@sifive.com>


Thanks!
diff mbox series

Patch

diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
index dd9138104568..ddf697b29df9 100644
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
@@ -78,6 +78,6 @@  obj-$(CONFIG_H8300_TPU)			+= h8300_tpu.o
 obj-$(CONFIG_CLKSRC_ST_LPC)		+= clksrc_st_lpc.o
 obj-$(CONFIG_X86_NUMACHIP)		+= numachip.o
 obj-$(CONFIG_ATCPIT100_TIMER)		+= timer-atcpit100.o
-obj-$(CONFIG_RISCV_TIMER)		+= riscv_timer.o
+obj-$(CONFIG_RISCV_TIMER)		+= timer-riscv.o
 obj-$(CONFIG_CSKY_MP_TIMER)		+= timer-mp-csky.o
 obj-$(CONFIG_GX6605S_TIMER)		+= timer-gx6605s.o
diff --git a/drivers/clocksource/riscv_timer.c b/drivers/clocksource/timer-riscv.c
similarity index 100%
rename from drivers/clocksource/riscv_timer.c
rename to drivers/clocksource/timer-riscv.c