Message ID | 20231018080416.25931-2-anonolitunya@gmail.com |
---|---|
State | Superseded |
Headers | show |
Series | [v2] Staging: sm750fb: Rename display_control_adjust_sm750LE | expand |
On 18.10.2023 10:04, Dorcas AnonoLitunya wrote: > Rename function display_control_adjust_sm750LE to > display_control_adjust_sm750le. This further enforces snakecase naming > convention for consistent naming style throughout entire file. > > This change was suggested by Andi Shyti <andi.shyti@linux.intel.com> You can use Suggested-by tag here, if you wish (as per [1]) before Signed-off-by line. In the first line of the commit, "Staging" should be lowercase. All the best, Karolina ----- [1] - Documentation/process/submitting-patches.rst > > Signed-off-by: Dorcas AnonoLitunya <anonolitunya@gmail.com> > --- > > v2: Correctly spells Andi Shyti's name > > drivers/staging/sm750fb/ddk750_mode.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c > index f3f354831617..bcdd291d25c9 100644 > --- a/drivers/staging/sm750fb/ddk750_mode.c > +++ b/drivers/staging/sm750fb/ddk750_mode.c > @@ -14,7 +14,7 @@ > * in bit 29:27 of Display Control register. > */ > static unsigned long > -display_control_adjust_SM750LE(struct mode_parameter *mode_param, > +display_control_adjust_sm750le(struct mode_parameter *mode_param, > unsigned long disp_control) > { > unsigned long x, y; > @@ -125,7 +125,7 @@ static int program_mode_registers(struct mode_parameter *mode_param, > tmp |= DISPLAY_CTRL_HSYNC_PHASE; > > if (sm750_get_chip_type() == SM750LE) { > - display_control_adjust_SM750LE(mode_param, tmp); > + display_control_adjust_sm750le(mode_param, tmp); > } else { > reg = peek32(CRT_DISPLAY_CTRL) & > ~(DISPLAY_CTRL_VSYNC_PHASE |
On Wed, Oct 18, 2023 at 10:12:19AM +0200, Karolina Stolarek wrote: > On 18.10.2023 10:04, Dorcas AnonoLitunya wrote: > > Rename function display_control_adjust_sm750LE to > > display_control_adjust_sm750le. This further enforces snakecase naming > > convention for consistent naming style throughout entire file. > > > > This change was suggested by Andi Shyti <andi.shyti@linux.intel.com> > > You can use Suggested-by tag here, if you wish (as per [1]) before > Signed-off-by line. Yeah > > In the first line of the commit, "Staging" should be lowercase. There isn't really a rule on this. People do it either way. But, sure, in this directory it's a 404 lower case vs 51 upper case so better to follow the majority opinion. In outreachy people are way more strict about some process issues than we would be in real life. And that's fine, because it's an educational process. I just worry that there is a certain amount of bleed over where people start "correcting" people who haven't signed up to be in outreachy. regards, dan carpenter
diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c index f3f354831617..bcdd291d25c9 100644 --- a/drivers/staging/sm750fb/ddk750_mode.c +++ b/drivers/staging/sm750fb/ddk750_mode.c @@ -14,7 +14,7 @@ * in bit 29:27 of Display Control register. */ static unsigned long -display_control_adjust_SM750LE(struct mode_parameter *mode_param, +display_control_adjust_sm750le(struct mode_parameter *mode_param, unsigned long disp_control) { unsigned long x, y; @@ -125,7 +125,7 @@ static int program_mode_registers(struct mode_parameter *mode_param, tmp |= DISPLAY_CTRL_HSYNC_PHASE; if (sm750_get_chip_type() == SM750LE) { - display_control_adjust_SM750LE(mode_param, tmp); + display_control_adjust_sm750le(mode_param, tmp); } else { reg = peek32(CRT_DISPLAY_CTRL) & ~(DISPLAY_CTRL_VSYNC_PHASE |
Rename function display_control_adjust_sm750LE to display_control_adjust_sm750le. This further enforces snakecase naming convention for consistent naming style throughout entire file. This change was suggested by Andi Shyti <andi.shyti@linux.intel.com> Signed-off-by: Dorcas AnonoLitunya <anonolitunya@gmail.com> --- v2: Correctly spells Andi Shyti's name drivers/staging/sm750fb/ddk750_mode.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)