Message ID | 20241103223154.136127-1-ebiggers@kernel.org |
---|---|
Headers | show |
Series | Wire up CRC32 library functions to arch-optimized code | expand |
On Sun, 3 Nov 2024 at 23:32, Eric Biggers <ebiggers@kernel.org> wrote: > > From: Eric Biggers <ebiggers@google.com> > > Instead of registering the crc32-$arch and crc32c-$arch algorithms if > the arch-specific code was built, only register them when that code was > built *and* is not falling back to the base implementation at runtime. > > This avoids confusing users like btrfs which checks the shash driver > name to determine whether it is crc32c-generic. > > (It would also make sense to change btrfs to test the crc32_optimization > flags itself, so that it doesn't have to use the weird hack of parsing > the driver name. This change still makes sense either way though.) > > Signed-off-by: Eric Biggers <ebiggers@google.com> Reviewed-by: Ard Biesheuvel <ardb@kernel.org> > --- > crypto/crc32_generic.c | 8 ++++++-- > crypto/crc32c_generic.c | 8 ++++++-- > 2 files changed, 12 insertions(+), 4 deletions(-) > > diff --git a/crypto/crc32_generic.c b/crypto/crc32_generic.c > index cc064ea8240e..783a30b27398 100644 > --- a/crypto/crc32_generic.c > +++ b/crypto/crc32_generic.c > @@ -155,19 +155,23 @@ static struct shash_alg algs[] = {{ > .base.cra_ctxsize = sizeof(u32), > .base.cra_module = THIS_MODULE, > .base.cra_init = crc32_cra_init, > }}; > > +static int num_algs; > + > static int __init crc32_mod_init(void) > { > /* register the arch flavor only if it differs from the generic one */ > - return crypto_register_shashes(algs, 1 + IS_ENABLED(CONFIG_CRC32_ARCH)); > + num_algs = 1 + ((crc32_optimizations() & CRC32_LE_OPTIMIZATION) != 0); > + > + return crypto_register_shashes(algs, num_algs); > } > > static void __exit crc32_mod_fini(void) > { > - crypto_unregister_shashes(algs, 1 + IS_ENABLED(CONFIG_CRC32_ARCH)); > + crypto_unregister_shashes(algs, num_algs); > } > > subsys_initcall(crc32_mod_init); > module_exit(crc32_mod_fini); > > diff --git a/crypto/crc32c_generic.c b/crypto/crc32c_generic.c > index 04b03d825cf4..985da981d6e2 100644 > --- a/crypto/crc32c_generic.c > +++ b/crypto/crc32c_generic.c > @@ -195,19 +195,23 @@ static struct shash_alg algs[] = {{ > .base.cra_ctxsize = sizeof(struct chksum_ctx), > .base.cra_module = THIS_MODULE, > .base.cra_init = crc32c_cra_init, > }}; > > +static int num_algs; > + > static int __init crc32c_mod_init(void) > { > /* register the arch flavor only if it differs from the generic one */ > - return crypto_register_shashes(algs, 1 + IS_ENABLED(CONFIG_CRC32_ARCH)); > + num_algs = 1 + ((crc32_optimizations() & CRC32C_OPTIMIZATION) != 0); > + > + return crypto_register_shashes(algs, num_algs); > } > > static void __exit crc32c_mod_fini(void) > { > - crypto_unregister_shashes(algs, 1 + IS_ENABLED(CONFIG_CRC32_ARCH)); > + crypto_unregister_shashes(algs, num_algs); > } > > subsys_initcall(crc32c_mod_init); > module_exit(crc32c_mod_fini); > > -- > 2.47.0 > >
On Mon, Nov 04, 2024 at 07:59:00AM -0800, Darrick J. Wong wrote: > Hmm. Looking at your git branch (which was quite helpful to link to!) I > think for XFS we don't need to change the crc32c() calls, and the only > porting work that needs to be done is mirroring this Kconfig change? > And that doesn't even need to be done until someone wants to get rid of > CONFIG_LIBCRC32C, right? That's correct, no porting work is required now. 'select LIBCRC32C' should be replaced with 'select CRC32', but that can be done later. > > @@ -3278,15 +3263,11 @@ extern void ext4_group_desc_csum_set(struct super_block *sb, __u32 group, > > extern int ext4_register_li_request(struct super_block *sb, > > ext4_group_t first_not_zeroed); > > > > static inline int ext4_has_metadata_csum(struct super_block *sb) > > { > > - WARN_ON_ONCE(ext4_has_feature_metadata_csum(sb) && > > - !EXT4_SB(sb)->s_chksum_driver); > > - > > - return ext4_has_feature_metadata_csum(sb) && > > - (EXT4_SB(sb)->s_chksum_driver != NULL); > > + return ext4_has_feature_metadata_csum(sb); > > } > > Nit: Someone might want to > s/ext4_has_metadata_csum/ext4_has_feature_metadata_csum/ here to get rid > of the confusingly named trivial helper. > Yes, that should be done as a follow-up patch. > Otherwise this logic looks ok to me, so > Reviewed-by: Darrick J. Wong <djwong@kernel.org> > > --D Thanks, - Eric