Message ID | 58acb4a8a4e98089078de3ed71999730b6d97b4b.1375521724.git.viresh.kumar@linaro.org |
---|---|
State | New |
Headers | show |
minor nitpick. $subject: PM / OPP: On 08/03/2013 04:25 AM, Viresh Kumar wrote: > Export opp_add() so that modules can use it. > > Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> > --- > drivers/base/power/opp.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c > index c8ec186..ef89897 100644 > --- a/drivers/base/power/opp.c > +++ b/drivers/base/power/opp.c > @@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt) > srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); > return 0; > } > +EXPORT_SYMBOL_GPL(opp_add); > > /** > * opp_set_availability() - helper to set the availability of an opp > other than that, Acked-by: Nishanth Menon <nm@ti.com>
On Monday, August 05, 2013 07:29:09 AM Nishanth Menon wrote: > minor nitpick. > $subject: PM / OPP: Those are things I can easily fix up when I'm applying the patch. > On 08/03/2013 04:25 AM, Viresh Kumar wrote: > > Export opp_add() so that modules can use it. > > > > Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> > > --- > > drivers/base/power/opp.c | 1 + > > 1 file changed, 1 insertion(+) > > > > diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c > > index c8ec186..ef89897 100644 > > --- a/drivers/base/power/opp.c > > +++ b/drivers/base/power/opp.c > > @@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt) > > srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); > > return 0; > > } > > +EXPORT_SYMBOL_GPL(opp_add); > > > > /** > > * opp_set_availability() - helper to set the availability of an opp > > > other than that, > Acked-by: Nishanth Menon <nm@ti.com> > >
On 5 August 2013 18:17, Rafael J. Wysocki <rjw@sisk.pl> wrote: > On Monday, August 05, 2013 07:29:09 AM Nishanth Menon wrote: >> minor nitpick. >> $subject: PM / OPP: Stupid mistake. > Those are things I can easily fix up when I'm applying the patch. Thanks :)
On 08/03/2013 02:25 AM, Viresh Kumar wrote: > Export opp_add() so that modules can use it. > > Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> > --- > drivers/base/power/opp.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c > index c8ec186..ef89897 100644 > --- a/drivers/base/power/opp.c > +++ b/drivers/base/power/opp.c > @@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt) > srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); > return 0; > } > +EXPORT_SYMBOL_GPL(opp_add); Could it be renamed to pm_opp_add() or power_opp_add() ? The name is a bit too unspecific IMO. > > /** > * opp_set_availability() - helper to set the availability of an opp >
change in subject to reflect new discussion. On 05:53-20130806, Randy Dunlap wrote: > On 08/03/2013 02:25 AM, Viresh Kumar wrote: > >Export opp_add() so that modules can use it. > > > >Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> > >--- > > drivers/base/power/opp.c | 1 + > > 1 file changed, 1 insertion(+) > > > >diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c > >index c8ec186..ef89897 100644 > >--- a/drivers/base/power/opp.c > >+++ b/drivers/base/power/opp.c > >@@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt) > > srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); > > return 0; > > } > >+EXPORT_SYMBOL_GPL(opp_add); > > Could it be renamed to pm_opp_add() or power_opp_add() ? > The name is a bit too unspecific IMO. Though this has nothing specific with this patch, an interesting point. git grep -w opp . showed drivers/tty/n_tty.c, drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using variables named opp to mean what ever they had in context. rest(around 40 odd files) seem to use opp as in Documentation/power/opp.txt.. We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more specific, though I prefer just pm_. If Rafael and others are ok, I can post a series out.
On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote: > change in subject to reflect new discussion. > > On 05:53-20130806, Randy Dunlap wrote: > > On 08/03/2013 02:25 AM, Viresh Kumar wrote: > > >Export opp_add() so that modules can use it. > > > > > >Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> > > >--- > > > drivers/base/power/opp.c | 1 + > > > 1 file changed, 1 insertion(+) > > > > > >diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c > > >index c8ec186..ef89897 100644 > > >--- a/drivers/base/power/opp.c > > >+++ b/drivers/base/power/opp.c > > >@@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt) > > > srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); > > > return 0; > > > } > > >+EXPORT_SYMBOL_GPL(opp_add); > > > > Could it be renamed to pm_opp_add() or power_opp_add() ? > > The name is a bit too unspecific IMO. > Though this has nothing specific with this patch, an interesting point. > > git grep -w opp . showed drivers/tty/n_tty.c, > drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using > variables named opp to mean what ever they had in context. rest(around > 40 odd files) seem to use opp as in Documentation/power/opp.txt.. > > We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more > specific, though I prefer just pm_. If Rafael and others are ok, I can > post a series out. Yup, that would be useful. I'm for dev_pm_opp_ if that matters. Thanks, Rafael
Rafael, offline question: On 08/06/2013 09:15 AM, Rafael J. Wysocki wrote: > On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote: >> change in subject to reflect new discussion. >> >> On 05:53-20130806, Randy Dunlap wrote: >>> On 08/03/2013 02:25 AM, Viresh Kumar wrote: >>>> +EXPORT_SYMBOL_GPL(opp_add); >>> >>> Could it be renamed to pm_opp_add() or power_opp_add() ? >>> The name is a bit too unspecific IMO. >> Though this has nothing specific with this patch, an interesting point. >> >> git grep -w opp . showed drivers/tty/n_tty.c, >> drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using >> variables named opp to mean what ever they had in context. rest(around >> 40 odd files) seem to use opp as in Documentation/power/opp.txt.. >> >> We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more >> specific, though I prefer just pm_. If Rafael and others are ok, I can >> post a series out. > > Yup, that would be useful. I'm for dev_pm_opp_ if that matters. Given that there would be quiet a few conflicts, do you have a suggestion around what baseline I should submit this?
On Wednesday, August 07, 2013 10:48:54 AM Nishanth Menon wrote: > Rafael, > offline question: Not really offline. :-) > On 08/06/2013 09:15 AM, Rafael J. Wysocki wrote: > > On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote: > >> change in subject to reflect new discussion. > >> > >> On 05:53-20130806, Randy Dunlap wrote: > >>> On 08/03/2013 02:25 AM, Viresh Kumar wrote: > > >>>> +EXPORT_SYMBOL_GPL(opp_add); > >>> > >>> Could it be renamed to pm_opp_add() or power_opp_add() ? > >>> The name is a bit too unspecific IMO. > >> Though this has nothing specific with this patch, an interesting point. > >> > >> git grep -w opp . showed drivers/tty/n_tty.c, > >> drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using > >> variables named opp to mean what ever they had in context. rest(around > >> 40 odd files) seem to use opp as in Documentation/power/opp.txt.. > >> > >> We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more > >> specific, though I prefer just pm_. If Rafael and others are ok, I can > >> post a series out. > > > > Yup, that would be useful. I'm for dev_pm_opp_ if that matters. > > Given that there would be quiet a few conflicts, do you have a > suggestion around what baseline I should submit this? Well, ideally, on top of 3.12-rc1 when it's out and put it into linux-next right after that. Thanks, Rafael
On 08/07/2013 05:53 PM, Rafael J. Wysocki wrote: > On Wednesday, August 07, 2013 10:48:54 AM Nishanth Menon wrote: >> Rafael, >> offline question: > > Not really offline. :-) > :D.. >> On 08/06/2013 09:15 AM, Rafael J. Wysocki wrote: >>> On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote: >>>> change in subject to reflect new discussion. >>>> >>>> On 05:53-20130806, Randy Dunlap wrote: >>>>> On 08/03/2013 02:25 AM, Viresh Kumar wrote: >> >>>>>> +EXPORT_SYMBOL_GPL(opp_add); >>>>> >>>>> Could it be renamed to pm_opp_add() or power_opp_add() ? >>>>> The name is a bit too unspecific IMO. >>>> Though this has nothing specific with this patch, an interesting point. >>>> >>>> git grep -w opp . showed drivers/tty/n_tty.c, >>>> drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using >>>> variables named opp to mean what ever they had in context. rest(around >>>> 40 odd files) seem to use opp as in Documentation/power/opp.txt.. >>>> >>>> We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more >>>> specific, though I prefer just pm_. If Rafael and others are ok, I can >>>> post a series out. >>> >>> Yup, that would be useful. I'm for dev_pm_opp_ if that matters. >> >> Given that there would be quiet a few conflicts, do you have a >> suggestion around what baseline I should submit this? > > Well, ideally, on top of 3.12-rc1 when it's out and put it into linux-next > right after that. Will do. Thanks on the hint.
diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c index c8ec186..ef89897 100644 --- a/drivers/base/power/opp.c +++ b/drivers/base/power/opp.c @@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt) srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); return 0; } +EXPORT_SYMBOL_GPL(opp_add); /** * opp_set_availability() - helper to set the availability of an opp
Export opp_add() so that modules can use it. Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> --- drivers/base/power/opp.c | 1 + 1 file changed, 1 insertion(+)