[Branch,~linaro-validation/lava-dispatcher/trunk] Rev 671: Clean up of setup.py

Message ID 20130905215426.4413.11776.launchpad@ackee.canonical.com
State Accepted
Headers show

Commit Message

Tyler Baker Sept. 5, 2013, 9:54 p.m.
------------------------------------------------------------
revno: 671
committer: Tyler Baker <tyler.baker@linaro.org>
branch nick: lava-dispatcher
timestamp: Thu 2013-09-05 14:53:57 -0700
message:
  Clean up of setup.py
modified:
  setup.py


--
lp:lava-dispatcher
https://code.launchpad.net/~linaro-validation/lava-dispatcher/trunk

You are subscribed to branch lp:lava-dispatcher.
To unsubscribe from this branch go to https://code.launchpad.net/~linaro-validation/lava-dispatcher/trunk/+edit-subscription

Patch

=== modified file 'setup.py'
--- setup.py	2013-09-05 21:21:42 +0000
+++ setup.py	2013-09-05 21:53:57 +0000
@@ -9,7 +9,7 @@ 
     license='GPL v2 or later',
     description="Part of the LAVA framework for dispatching test jobs",
     author='Linaro Validation Team',
-    author_email='linaro-dev@lists.linaro.org',
+    author_email='linaro-validation@lists.linaro.org',
     namespace_packages=['lava'],
     entry_points="""
     [lava.commands]
@@ -31,7 +31,6 @@ 
             'default-config/lava-dispatcher/device-defaults.conf',
             'default-config/lava-dispatcher/device-types/*.conf',
             'default-config/lava-dispatcher/devices/*.conf',
-            'device/sdmux.sh',
         ],
     },
     data_files=[
@@ -45,15 +44,15 @@ 
             ])
     ],
     install_requires=[
-        "json-schema-validator >= 2.3",
-        "lava-tool >= 0.4",
-        "lava-utils-interface",
-        "linaro-dashboard-bundle",
-        "pexpect >= 2.3",
-        "configglue",
-        "PyYAML",
+        'json-schema-validator >= 2.3',
+        'lava-tool >= 0.4',
+        'lava-utils-interface',
+        'linaro-dashboard-bundle',
+        'pexpect >= 2.3',
+        'configglue',
+        'PyYAML',
         'versiontools >= 1.8',
-        "pyserial >= 2.6",
+        'pyserial >= 2.6',
     ],
     setup_requires=[
         'versiontools >= 1.8',