diff mbox series

[net-next,1/2] dt-bindings: net: nfc: s3fwrn5: Support a UART interface

Message ID 20201123075526epcms2p59410a8ba942f8942f53a593d9df764d0@epcms2p5
State New
Headers show
Series [net-next,1/2] dt-bindings: net: nfc: s3fwrn5: Support a UART interface | expand

Commit Message

Bongsu Jeon Nov. 23, 2020, 7:55 a.m. UTC
Since S3FWRN82 NFC Chip, The UART interface can be used.
S3FWRN82 supports I2C and UART interface.

Signed-off-by: Bongsu Jeon <bongsu.jeon@samsung.com>
---
 .../bindings/net/nfc/samsung,s3fwrn5.yaml     | 28 +++++++++++++++++--
 1 file changed, 26 insertions(+), 2 deletions(-)

Comments

Krzysztof Kozlowski Nov. 24, 2020, 11:41 a.m. UTC | #1
On Tue, Nov 24, 2020 at 08:39:40PM +0900, Bongsu Jeon wrote:
> On Mon, Nov 23, 2020 at 5:02 PM krzk@kernel.org <krzk@kernel.org> wrote:
> >
> > On Mon, Nov 23, 2020 at 04:55:26PM +0900, Bongsu Jeon wrote:
 > >  examples:
> > >    - |
> > >      #include <dt-bindings/gpio/gpio.h>
> > > @@ -71,3 +81,17 @@ examples:
> > >              wake-gpios = <&gpj0 2 GPIO_ACTIVE_HIGH>;
> > >          };
> > >      };
> > > +  # UART example on Raspberry Pi
> > > +  - |
> > > +    &uart0 {
> > > +        status = "okay";
> > > +
> > > +        s3fwrn82_uart {
> >
> > Just "bluetooth" to follow Devicetree specification.
> Sorry. I don't understand this comment.
> Could you explain it?
> Does it mean i need to refer to the net/broadcom-bluetooth.txt?

The node name should be "bluetooth", not "s3fwrn82_uart", because of
Devicetree naming convention - node names should represent generic class
of a device.

Best regards,
Krzysztof
Bongsu Jeon Nov. 25, 2020, 3:08 a.m. UTC | #2
On 11/24/20, krzk@kernel.org <krzk@kernel.org> wrote:
> On Tue, Nov 24, 2020 at 08:39:40PM +0900, Bongsu Jeon wrote:

>> On Mon, Nov 23, 2020 at 5:02 PM krzk@kernel.org <krzk@kernel.org> wrote:

>> >

>> > On Mon, Nov 23, 2020 at 04:55:26PM +0900, Bongsu Jeon wrote:

>  > >  examples:

>> > >    - |

>> > >      #include <dt-bindings/gpio/gpio.h>

>> > > @@ -71,3 +81,17 @@ examples:

>> > >              wake-gpios = <&gpj0 2 GPIO_ACTIVE_HIGH>;

>> > >          };

>> > >      };

>> > > +  # UART example on Raspberry Pi

>> > > +  - |

>> > > +    &uart0 {

>> > > +        status = "okay";

>> > > +

>> > > +        s3fwrn82_uart {

>> >

>> > Just "bluetooth" to follow Devicetree specification.

>> Sorry. I don't understand this comment.

>> Could you explain it?

>> Does it mean i need to refer to the net/broadcom-bluetooth.txt?

>

> The node name should be "bluetooth", not "s3fwrn82_uart", because of

> Devicetree naming convention - node names should represent generic class

> of a device.

>

Actually, RN82 is the nfc device.
So, is it okay to use the name as nfc instead of Bluetooth?

> Best regards,

> Krzysztof

>

>
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/net/nfc/samsung,s3fwrn5.yaml b/Documentation/devicetree/bindings/net/nfc/samsung,s3fwrn5.yaml
index cb0b8a560282..37b3e5ae5681 100644
--- a/Documentation/devicetree/bindings/net/nfc/samsung,s3fwrn5.yaml
+++ b/Documentation/devicetree/bindings/net/nfc/samsung,s3fwrn5.yaml
@@ -13,6 +13,7 @@  maintainers:
 properties:
   compatible:
     const: samsung,s3fwrn5-i2c
+    const: samsung,s3fwrn82-uart
 
   en-gpios:
     maxItems: 1
@@ -47,10 +48,19 @@  additionalProperties: false
 required:
   - compatible
   - en-gpios
-  - interrupts
-  - reg
   - wake-gpios
 
+allOf:
+  - if:
+      properties:
+        compatible:
+          contains:
+            const: samsung,s3fwrn5-i2c
+    then:
+      required:
+        - interrupts
+        - reg
+
 examples:
   - |
     #include <dt-bindings/gpio/gpio.h>
@@ -71,3 +81,17 @@  examples:
             wake-gpios = <&gpj0 2 GPIO_ACTIVE_HIGH>;
         };
     };
+  # UART example on Raspberry Pi
+  - |
+    &uart0 {
+        status = "okay";
+
+        s3fwrn82_uart {
+            compatible = "samsung,s3fwrn82-uart";
+
+            en-gpios = <&gpio 20 0>;
+            wake-gpios = <&gpio 16 0>;
+
+            status = "okay";
+        };
+    };