diff mbox series

[7/7] Remove scsi_get_lba()

Message ID 20210509214307.4610-8-bvanassche@acm.org
State Superseded
Headers show
Series Rename scsi_get_lba() into scsi_get_pos() | expand

Commit Message

Bart Van Assche May 9, 2021, 9:43 p.m. UTC
Remove scsi_get_lba() since all callers have been converted to
scsi_get_pos().

Signed-off-by: Bart Van Assche <bvanassche@acm.org>
---
 include/scsi/scsi_cmnd.h | 5 -----
 1 file changed, 5 deletions(-)
diff mbox series

Patch

diff --git a/include/scsi/scsi_cmnd.h b/include/scsi/scsi_cmnd.h
index 8147b1c0f265..f8084efa9838 100644
--- a/include/scsi/scsi_cmnd.h
+++ b/include/scsi/scsi_cmnd.h
@@ -285,11 +285,6 @@  static inline unsigned char scsi_get_prot_type(struct scsi_cmnd *scmd)
 	return scmd->prot_type;
 }
 
-static inline sector_t scsi_get_lba(struct scsi_cmnd *scmd)
-{
-	return blk_rq_pos(scmd->request);
-}
-
 static inline sector_t scsi_get_pos(struct scsi_cmnd *scmd)
 {
 	return blk_rq_pos(scmd->request);