mbox series

[v5,0/2] add MSI support for PCIe port services and DPC IRQ support

Message ID 1495549439-10372-1-git-send-email-gabriele.paoloni@huawei.com
Headers show
Series add MSI support for PCIe port services and DPC IRQ support | expand

Message

Gabriele Paoloni May 23, 2017, 2:23 p.m. UTC
From: gabriele paoloni <gabriele.paoloni@huawei.com>


This patchset:
1) adds support for MSI interrupt vectors to be used for Roor Port services
2) adds support for DPC Root Port service interrupt

The patchset has been tested on Hisilicon Hip08 Chipset

Changes from v4:
- removed meaningless comment

Changes from v3:
- removed 2 extra lines at the bottom of comments

Changes from v2:
- Fixed comment mismatch for function pcie_port_enable_irq_vec
- removed redundant commet on pci_irq_vector()

Changes from v1:
According to comments from Christoph Hellwig in
https://www.spinics.net/lists/kernel/msg2508842.html
and
https://www.spinics.net/lists/kernel/msg2508850.html

- reduced the calls of pci_alloc_irq_vectors by ORing PCI_IRQ_MSIX and 
  PCI_IRQ_MSI
- used a unique macro for the max number of MSI/MSIx interrupt vectors
- reworked pcie_init_service_irqs() to call pci_alloc_irq_vectors() only
  for legacy IRQ


Gabriele Paoloni (1):
  PCI/portdrv: add support for different MSI interrupts for PCIe port
    services

gabriele paoloni (1):
  PCI/portdrv: allocate MSI/MSIx vector for DPC RP service

 drivers/pci/pcie/portdrv.h      |  8 ++++--
 drivers/pci/pcie/portdrv_core.c | 63 +++++++++++++++++++++++++++++------------
 2 files changed, 50 insertions(+), 21 deletions(-)

-- 
2.7.4

Comments

Bjorn Helgaas June 17, 2017, 12:37 a.m. UTC | #1
On Tue, May 23, 2017 at 03:23:57PM +0100, Gabriele Paoloni wrote:
> From: gabriele paoloni <gabriele.paoloni@huawei.com>

> 

> This patchset:

> 1) adds support for MSI interrupt vectors to be used for Roor Port services

> 2) adds support for DPC Root Port service interrupt

> 

> The patchset has been tested on Hisilicon Hip08 Chipset

> 

> Changes from v4:

> - removed meaningless comment

> 

> Changes from v3:

> - removed 2 extra lines at the bottom of comments

> 

> Changes from v2:

> - Fixed comment mismatch for function pcie_port_enable_irq_vec

> - removed redundant commet on pci_irq_vector()

> 

> Changes from v1:

> According to comments from Christoph Hellwig in

> https://www.spinics.net/lists/kernel/msg2508842.html

> and

> https://www.spinics.net/lists/kernel/msg2508850.html

> 

> - reduced the calls of pci_alloc_irq_vectors by ORing PCI_IRQ_MSIX and 

>   PCI_IRQ_MSI

> - used a unique macro for the max number of MSI/MSIx interrupt vectors

> - reworked pcie_init_service_irqs() to call pci_alloc_irq_vectors() only

>   for legacy IRQ

> 

> 

> Gabriele Paoloni (1):

>   PCI/portdrv: add support for different MSI interrupts for PCIe port

>     services

> 

> gabriele paoloni (1):

>   PCI/portdrv: allocate MSI/MSIx vector for DPC RP service

> 

>  drivers/pci/pcie/portdrv.h      |  8 ++++--

>  drivers/pci/pcie/portdrv_core.c | 63 +++++++++++++++++++++++++++++------------

>  2 files changed, 50 insertions(+), 21 deletions(-)


Applied to pci/portdrv for v4.13, thanks!

I tweaked the PME/hotplug no-MSI logic in pcie_init_service_irqs()
because I thought it was getting hard to read with the negations and
conjunctions.  Please double-check to make sure I didn't break it.

https://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git/log/?h=pci/portdrv

I also capitalized your name consistently, Gabriele :)
Gabriele Paoloni June 19, 2017, 1:19 p.m. UTC | #2
Hi Bjorn

[...]

++++++++++++++--
> ----------

> >  2 files changed, 50 insertions(+), 21 deletions(-)

> 

> Applied to pci/portdrv for v4.13, thanks!

> 

> I tweaked the PME/hotplug no-MSI logic in pcie_init_service_irqs()

> because I thought it was getting hard to read with the negations and

> conjunctions.  Please double-check to make sure I didn't break it.


liudongdong tested the patchset as reworked in your branch and it works
ok 

> 

> https://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git/log/?h=

> pci/portdrv

> 

> I also capitalized your name consistently, Gabriele :)


Many thanks, next time I should be consistent with myself :)

Cheers
Gab