diff mbox series

[v3,01/18] dt-bindings: power: battery: add constant-charge-current property

Message ID 20170214094112.27426-2-quentin.schulz@free-electrons.com
State New
Headers show
Series add support for AXP20X and AXP22X power supply drivers | expand

Commit Message

Quentin Schulz Feb. 14, 2017, 9:40 a.m. UTC
This adds the constant-charge-current property to the list of optional
properties of the battery.

The constant charge current is critical for batteries as they can't
handle all charge currents.

Signed-off-by: Quentin Schulz <quentin.schulz@free-electrons.com>

---

added in v3

 Documentation/devicetree/bindings/power/supply/battery.txt | 2 ++
 1 file changed, 2 insertions(+)

-- 
2.9.3

Comments

Rob Herring Feb. 22, 2017, 9:25 p.m. UTC | #1
On Tue, Feb 14, 2017 at 10:40:55AM +0100, Quentin Schulz wrote:
> This adds the constant-charge-current property to the list of optional

> properties of the battery.

> 

> The constant charge current is critical for batteries as they can't

> handle all charge currents.

> 

> Signed-off-by: Quentin Schulz <quentin.schulz@free-electrons.com>

> ---

> 

> added in v3

> 

>  Documentation/devicetree/bindings/power/supply/battery.txt | 2 ++

>  1 file changed, 2 insertions(+)

> 

> diff --git a/Documentation/devicetree/bindings/power/supply/battery.txt b/Documentation/devicetree/bindings/power/supply/battery.txt

> index d78a4aa..3e830fe 100644

> --- a/Documentation/devicetree/bindings/power/supply/battery.txt

> +++ b/Documentation/devicetree/bindings/power/supply/battery.txt

> @@ -7,6 +7,7 @@ Optional Properties:

>   - voltage-min-design-microvolt: drained battery voltage

>   - energy-full-design-microwatt-hours: battery design energy

>   - charge-full-design-microamp-hours: battery design capacity

> + - constant-charge-current-microamp: battery constant charge current


Kind of long, though so are the others. Maybe just 
"constant-charge-microamp" as uA implies current.

Otherwise,

Acked-by: Rob Herring <robh@kernel.org>
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/power/supply/battery.txt b/Documentation/devicetree/bindings/power/supply/battery.txt
index d78a4aa..3e830fe 100644
--- a/Documentation/devicetree/bindings/power/supply/battery.txt
+++ b/Documentation/devicetree/bindings/power/supply/battery.txt
@@ -7,6 +7,7 @@  Optional Properties:
  - voltage-min-design-microvolt: drained battery voltage
  - energy-full-design-microwatt-hours: battery design energy
  - charge-full-design-microamp-hours: battery design capacity
+ - constant-charge-current-microamp: battery constant charge current
 
 Future Properties must be named for the corresponding elements in
 enum power_supply_property, defined in include/linux/power_supply.h.
@@ -22,6 +23,7 @@  Example:
 		voltage-min-design-microvolt = <3200000>;
 		energy-full-design-microwatt-hours = <5290000>;
 		charge-full-design-microamp-hours = <1430000>;
+		constant-charge-current-microamp = <300000>;
 	};
 
 	charger: charger@11 {